00_video_decode freeze in non-blocking mode

Hi,

lastes l4t release

# cat /etc/nv_tegra_release 
# R32 (release), REVISION: 4.3, GCID: 21589087, BOARD: t186ref, EABI: aarch64, DATE: Fri Jun 26 04:34:27 UTC 2020

when i run

./video_decode H264 --blocking-mode 0 --disable-rendering /usr/src/jetson_
multimedia_api/data/Video/sample_outdoor_car_1080p_10fps.h264

video_decode freeze with output:

# time ./video_decode H264 --blocking-mode 0 --disable-rendering /usr/src/
multimedia_api/data/Video/sample_outdoor_car_1080p_10fps.h264
Set governor to performance before enabling profiler
Creating decoder in non-blocking mode
Opening in O_NONBLOCKING MODE
NvMMLiteOpen : Block : BlockType = 261
NVMEDIA: Reading vendor.tegra.display-size : status: 6
NvMMLiteBlockCreate : Block : BlockType = 261
Setting frame input mode to 1
Created the PollThread and Decoder Thread
Starting Device Poll Thread
Capture plane not ON, skipping capture plane
Capture plane not ON, skipping capture plane
....
Got V4L2_EVENT_RESOLUTION_CHANGE EVENT
Video Resolution: 1920x1080
Decoder colorspace ITU-R BT.601 with standard range luma (16-235)
Query and set capture successful

^C

real    0m22,321s
user    0m9,000s
sys     0m19,908s

In blocking mode video_decode work well.

Hi,
It runs OK in rendering:

$ ./video_decode H264 --blocking-mode 0 ../../data/Video/sample_outdoor_car_1080p_10fps.h264

and dump to a file:

$ ./video_decode H264 --blocking-mode 0 --disable-rendering -o /home/nvidia/dump.yuv ../../data/Video/sample_outdoor_car_1080p_10fps.h264

We thinks it is a valid usecase to run –disable-rendering -o together. please give it a try.

Thanks, works for me