100% CPU usage while tracking objects using dlib

Hi all,

My Python application hung when I tried to track objects using dlib in Jetson TX2, and when I ran tegrastats, I found that all 6 cores had 100% usage while GPU usage was less than 20%.

After some troubleshooting, I found that the root cause was http://dlib.net/python/index.html#dlib.correlation_tracker.update. I also checked the dlib.DLIB_USE_CUDA flag and it’s True.

Can anyone please help? Thanks.

Brian Yang

Hi,

https://github.com/davisking/dlib/issues/1447
It looks like this is under expectation.

The the stuck, would you mind to check the memory usage from tegrastats?

Thanks.

I’m now flashing the TX2 again, try to get a clean installation of dlib. Previously I installed TensorFlow 1.15 before dlib.

But the weird part is that the same Python script doesn’t hang in Jetson Nano, even the dlib version is the same (19.16).

After reinstalling dlib without commenting out the line (which was suggested by https://devtalk.nvidia.com/default/topic/1049660/jetson-nano/issues-with-dlib-library/post/5336330/#5336330):

forward_algo = forward_best_algo;

The Python application doesn’t hang anymore. I believe because I’m running JetPack 4.3 which has cuDNN 7.6.3, which has fixed this issue just as https://devtalk.nvidia.com/default/topic/1049660/jetson-nano/issues-with-dlib-library/post/5346948/#5346948 confirmed.

Thanks.

Good to know this.
Thanks for updating the status with us.