1660 Super not detected by nvidia-smi though detected by Ubuntu 22.04

I’ve virtualized Ubuntu 22.04 on proxmox, and passed through the GPU. running ubuntu-drivers devices I get

~$ ubuntu-drivers devices
ERROR:root:aplay command not found
== /sys/devices/pci0000:00/0000:00:10.0 ==
modalias : pci:v000010DEd000021C4sv00001458sd00004013bc03sc00i00
vendor   : NVIDIA Corporation
model    : TU116 [GeForce GTX 1660 SUPER]
driver   : nvidia-driver-470-server - distro non-free
driver   : nvidia-driver-545-open - distro non-free
driver   : nvidia-driver-535 - distro non-free recommended
driver   : nvidia-driver-450-server - distro non-free
driver   : nvidia-driver-535-server - distro non-free
driver   : nvidia-driver-535-server-open - distro non-free
driver   : nvidia-driver-545 - distro non-free
driver   : nvidia-driver-535-open - distro non-free
driver   : nvidia-driver-470 - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

Ubuntu detects the GPU is there however when running nvidia smi

~$ nvidia-smi
No devices were found

To install the drivers I used sudo ubuntu-drivers autoinstall and got no errors during the install, followed by a restart
I then tried blacklisting the nouveau drivers as recommended by a youtube video by editing /etc/modprobe.d/blacklist.conf and adding blacklist nouveau. This had no effect.
I then ran sudo apt remove --purge '^nvidia-.*' -y and rebooted, tried the install steps again and still got the No devices were found output of nvidia-smi.

nvidia-bug-report.log.gz (74.9 KB)

NVRM: GPU 0000:00:10.0: GPU does not have the necessary power cables connected.

Ah thanks, I was afraid it was a hardware problem. Will check out the server, thanks for pointing me in the right direction

If you find that the GPU has a plug connected, make sure it’s an 8-pin PCI-e plug. A 6-pin plug will fit in there, but won’t give enough power and lead to the error. It’s an easy mistake to make if you don’t look closely at the connector.