1660ti under Ubuntu cannot recognize the extended screen

I installed the NVIDIA driver, but still couldn’t recognize the second screen, and NVIDIA X server settings couldn’t be opened. This is bug report.
nvidia-bug-report.log.gz (1.11 MB)

Please delete /etc/X11/xorg.conf, then install the package nvidia-prime (sudo apt install nvidia-prime) and switch to the nvidia profile (sudo prime-select nvidia), then reboot. Afterwards, create a new nvidia-bug-report.log.
How did you install the driver?

When i switch to the nvidia profile,some mistakes have occurred:
Info: the current GL alternatives in use are: [‘mesa’, None]
Info: the current EGL alternatives in use are: [‘mesa-egl’, None]
Error: the installed packages do not support PRIME
Error: nvidia mode can’t be enabled

I installed the driver through the. run file

Ok, that won’t work.
Please follow this:

  • Don’t use the .run installers, use --uninstall to uninstall them
  • add the ubuntu graphics ppa https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
  • install the driver from that (sudo apt install nvidia-430)
  • install nvidia-prime (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • reboot

I executed this process, but there was an error after restarting: the system is running in low-graphics mode

Please create a new nvidia-bug-report.log and attach it.

When I replaced nvidia-430 with nvidia-418, the problem was solved.Thank you.