17.10 Community Edition install

I tried to install the community edition. When I start to use it, I get the following error:

pgcc: LICENSE MANAGER PROBLEM: Cannot find license file.
The license files (or license server system network addresses) attempted are
listed below. Use LM_LICENSE_FILE to use a different license file,
or contact your software provider for a license file.
Feature: pgcc
Filename: ./license.dat
License path: ./license.dat:
FlexNet Licensing error:-1,359. System Error: 2 “No such file or directory”
For further information, refer to the FlexNet Licensing documentation,
available at “www.flexerasoftware.com”.

Is there anything else that I am missing.

Two possible problems.

  1. you said yes to generating a license, and ended up failing to create one. Saying No would put the Community License in place. It does not use the license service, so do not run “lmgrd.rc start”

  2. Before you run the compilers, you need to define $PGI and put the
    compilers in your $PATH.
    export PGI=/opt/pgi ! if you installed in /opt/pgi
    export PATH=$PGI/linux86-64/17.10/bin:$PATH ! add path to compilers
    export PATH=$PGI/linux86-64/2017/mpi/openmpi/bin:$PATH ! add
    !path to mpi drivers mpif90, mpic++, mpicc

and then things should work.

The license is usually stored as $PGI/license.dat. Since you did not define $PGI, the compilers looked for ./license.dat

dave