173.14.36 Xinerama and Xserver 1.13.2

Good day. I’ve been running an older system with 5xxx graphics card, subject driver and 2 monitors using Twinview. I run slackware which recently updated the Xserver from 1.12.3 to 1.13.2. The driver recompiled fine after patching the build process but clients now that query Xinerama info are now returned no results which messes up window manager and other clients. Anyone else seeing this?

An update. Still the same issue with 173.14.37. Also tried this driver with a 68xx card and same thing happened. Any client that calls XineramaQueryScreens(,) is returned NULL. Since the 68xx is also supported by the 304.84 driver, I tried it and Xinerama worked as before. Apparently the 173 driver does not fully support the X13 ABI.

Thanks for the report. I filed bug 1253988 to look into this. Can you please look at the sticky posts about how to generate an nvidia-bug-report.log.gz file?

Please attach nvidia bug report and reproduction steps .

Just updated to Xorg 14.0 and the problem persists. The system I have handy uses the 6800 card. Bug report attached. Thanks.

Reproduction steps:

  • Start xterm in right screen, it gets created in the left.
  • Maximize any window, it will now span both screens.

Summary, Window Manager gets no Xinerama info.
nvidia-bug-report.log.gz (45.1 KB)

Correction on the previous post. With Xorg 14.0 XineramaQueryScreens(,) now returns 1 screen with dimensions 3200x1200.

With 13.2 this was NULL. My desktop is a 1280x1024 LCD as the left screen and 1920x1200 LCD as the right screen. Previous to 13.2, this was reported as 2 screens.

Correction 2. With Xorg 14.0 XineramaQueryScreens(,) returns NULL. Run and close nvidia-settings. Then XineramaQueryScreens(,) returns 1. Buggy!