178.08 for Windows XP yes, it fixes the watchdog timer...

With the latest display driver? Please? :)

Why are you so concerned about the latest display driver? I honestly don’t get it.

v178.13 fixes a problem I was having with a game; and then I would have all driver components from the same “generation” (instead of having new CUDA/old display/unknown Physix), which simplifies maintenance. I work on CUDA on my own PC which needs to do other stuff too.

Does the new build improve device2device bandwidth, too? I lost 15% from 175.19 to 178.13. :(

I’m happy to report that with v178.08, device2device bandwidth is good again.

Almost at 175.xx levels, and +13% from 178.13 WHQL.

Fernando

And what’s the deal with 178.24?

Could someone please provide update on the driver status.

I have problem with the 10 second watchdog, and also with installation of the driver with non-NVIDIA graphics card :-( thought the watchdog problem might go away if I use non-NV graphics card for the display, and NV driver for the Tesla C1060.)

Filed bugs through developer portal, but no help.

Have been working around the 10 second watchdog problem by breaking long kernels into shorter ones, but it’s getting messy.

Any ETA on the resolution of these two problems?

Thanks,

Edin Hodzic

Look at the “178.28 …” thread in this forum, 178.28 really resolves the watchdog problem. However, links for download are now inactive, no ideas why.

they got pulled for some reason (there’s nothing wrong with the driver, I think it’s a bit of confusion with our web team) but should be back up today.

That’s encouraging, thanks for the info!

Hi TMurray,

the URLs:

178.28 for WinXP 32:

http://developer.download.nvidia.com/compu…(178_28)Int.exe, and

178.28 for WinXP 64:

http://developer.download.nvidia.com/compu…(178_28)Int.exe

are both still broken.

Any idea when they would be available?

Also, does the 64-bit driver fix the memory leak on the card when running with 32-bit applications?

Thanks,

Edin Hodzic

I’ve been tracking it, and I am a bit confused as to why they’re not online yet. I’ll ask around again tomorrow.

(also, I don’t know what the memory leak in 32-bit apps is)

I tried the following combination:

  • Windows XP 64-bit

  • CUDA driver 64-bit (for Windows XP 64)

  • CUDA toolkit and SDK for 32-bit (for Windows XP 32)

Each time I ran a 32 bit CUDA application, it would run fine, but after about ten runs, no new kernel would launch. Using cuMemGetInfo() I found that there was about 50MB of memory leak after each application execution (not after each kernel launch, one application could launch many kernels as long as it didn’t exit.) Perhaps some cleanup on application shutdown doesn’t happen in the case of 32-bit app on 64-bit WXP?!

I needed the 32-bit toolkit due to some of the packages I needed being available only as 32-bit libraries…

I guess Linux environment might be more stable?! Will have to browse the Linux forums…

I have tried 178.08 (and also 178.24), but with both versions I can’t use Cuda 2.0 applications as promised.
I’m sticked to Cuda 1.0.
I have a P4 3.4GHz and a 8800 GTS 640.

178.28 doesn’t also work with Cuda 2.0 application at my pc.

edit: found the answer
http://www.gpugrid.net/forum_thread.php?id=316