195.36.24 does not support cuda? versions of cuda driver & runtime mismatched

I’m using debian, and previously, I installed nvidia driver from official website and cuda worked.

Recently, due to the failure of loading nvidia module when I started google earth, I choose to install the latest
nvidia driver 195.36.24 from debian apt source.

However, since then, cuda never worked that no matter 2.30 or 3.0, when I ran deviceQuery, non-gpu device can be found!!! While there was no error during compiling by GCC 4.4.

I viewed the official website and found that in the page to download cuda toolkit 2.3, it supplies driver with version 190.xx.xx, while 195.36.18 for cuda toolkit 3.0.

Thus, I just think that the latest version 196.36.24 does not support neither 2.30 nor 3.0.

Who can help me?? My GPU is Geforce 9400 M G


the following is error code:

for toolkit 2.30, sdk 2.30:

CUDA Device Query (Runtime API) version (CUDART static linking)
There is no device supporting CUDA.

Device 0: “Device Emulation (CPU)”
CUDA Driver Version: 0.0
CUDA Runtime Version: 2.30

for toolkit 3.0, sdk 3.0:

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount FAILED CUDA Driver and Runtime version may be mismatched.



I am running the “official” version of 195.36.24 from NVIDIAs download server and it works perfectly with both 3.0 and 2.3. The Debian package is probably broken, so don’t use it.