2 problems: constantly lose wifi connection to nano, and can't install numpy

I have 2 problems with my Nano:

  1. I keep losing the WiFi connection to my Nano, but my PC sitting right next to it never loses the connection. The signal strength is ‘excellent’ on the PC. This has been going on for about 2 weeks. Re-booting the Nano sometimes works for awhile but it always loses the connection eventually.

  2. I try to install pytorch 1.1.0 or 1.3.0 but keep getting errors when numpy tries to set up.

I type: pip3 install torch-1.3.0-cp36-cp36m-linux_aarch64.whl

1st error message I get: Running setup.py bdist_wheel for numpy … error

2nd error message I get: ModuleNotFoundError: No module named ‘Cython’

Does anyone have any suggestions for either issue, or is more info needed?

Thanks

John

Hi, jp.saunders

1, Which wifi module are you trying with?
2. Pls try:

python3.6 -m pip install cython

Thank you for the quick response.

  1. I am using the Edimax EW-7811Un USB adapter. I see that other people on this forum have trouble with it as well. I have already tried disabling power save and that didn’t help, so I can try the jetson_clocks command suggested in another post. But is there a better USB WiFi adapter that doesn’t have these issues? I would be happy to buy that one instead if it works better.

  2. I am insalling cython now per your suggestion, and will update my post once I find out if everything is OK afterwards.

Here is an update:

  1. setting power_save to off does NOT help the problem. running the jetson_clocks command does not help either. Sometimes rebooting the Nano makes WiFi work again for awhile, but it always drops out eventually. Then it sometimes comes back if I wait a few minutes. It never consistently performs the same way, however. I don’t think I have had WiFi working for more than 1/2 hour at any one time.

  2. Installing Cython did allow PyTorch to install, and I confirmed it was OK in python terminal mode. However, TorchVision did not successfully load. I could not find any obvious error message from the installation, but here is what I get when I try to import torchvision in python terminal mode (I installed Pytoch 1.1.0 instead of 1.3.0 as I was originally trying to do in my first message):

import torchvision
Traceback (most recent call last):
File “”, line 1, in
File “/usr/local/lib/python3.6/dist-packages/torchvision-0.3.0-py3.6-linux-aarch64.egg/torchvision/init.py”, line 2, in
File “/usr/local/lib/python3.6/dist-packages/torchvision-0.3.0-py3.6-linux-aarch64.egg/torchvision/datasets/init.py”, line 9, in
File “/usr/local/lib/python3.6/dist-packages/torchvision-0.3.0-py3.6-linux-aarch64.egg/torchvision/datasets/fakedata.py”, line 3, in
File “/usr/local/lib/python3.6/dist-packages/torchvision-0.3.0-py3.6-linux-aarch64.egg/torchvision/transforms/init.py”, line 1, in
File “/usr/local/lib/python3.6/dist-packages/torchvision-0.3.0-py3.6-linux-aarch64.egg/torchvision/transforms/transforms.py”, line 17, in
File “/usr/local/lib/python3.6/dist-packages/torchvision-0.3.0-py3.6-linux-aarch64.egg/torchvision/transforms/functional.py”, line 5, in
ImportError: cannot import name ‘PILLOW_VERSION’

print(torchvision.version)
Traceback (most recent call last):
File “”, line 1, in
NameError: name ‘torchvision’ is not defined

Do you have any suggestion?

Thank you

Hi, jp.saunders

1, You can try with the intel 8265NGW wifi module.
2, Could you share your jetpack version? We need to align the env as well.

In the same time you could check with the followed guide to install it.

https://devtalk.nvidia.com/default/topic/1049071/jetson-nano/pytorch-for-jetson-nano-version-1-3-0-now-available/

sudo apt-get update
sudo apt install python3-pip python3-pil
sudo pip3 install --upgrade numpy 
sudo pip3 install torch-*-cp36-cp36m-linux_aarch64.whl
sudo pip3 install torchvision
  1. OK. For now I just switched to a wired ethernet connection.

  2. I don’t know how to read the version of Jetpack, but I downloaded the SD card image direct from the nvidia nano setup instructions on 11/29/2019, so I think it must be 4.2.3 according to the jetson download center (that version was the latest on 11/29/2019).

I will try the guide and see if that helps.

Thank you

another update:

I tried typing the 5 lines listed above in your last answer. Lines 1 and 2 worked fine, but lines 3-5 all had the same message saying that I did not have permission, and I should try using sudo with the -H option. So I did that, but then I got my original error message trying to upgrade numpy (no module named Cython found). So I reinstalled Cython again but that did not get rid of the ‘no Cython’ message.

I also tried installing torchvision as listed in the link you posted above, but that did not work for me either.

I feel like i am close because it appears PyTorch installed OK; I just cannot get torchvision to install.

Requirement already satisfied: torchvision in /usr/local/lib/python3.6/dist-packages (0.2.2.post3)
Requirement already satisfied: numpy in /usr/local/lib/python3.6/dist-packages (from torchvision) (1.17.3)
Requirement already satisfied: pillow>=4.1.1 in /usr/lib/python3/dist-packages (from torchvision) (5.1.0)
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from torchvision) (1.11.0)
Requirement already satisfied: torch in /usr/local/lib/python3.6/dist-packages (from torchvision) (1.0.0a0+18eef1d)
nvidia@nvidia-desktop:

It’s ok on my nano with jetpack 4.3.

Just reproduced your problems.

Pls try update your pip to the newest version.

sudo -H pip3 install --upgrade pip

Then try again. It should be work.