2 x GT650M cards in SLI prevent ttys from functioning and successful resume from sleep

Relevant system info:
Lenovo Ideapad Y500 (SLI and NO Optimus)
2 x GT 650M cards in SLI
Arch Linux 64-bit 3.9.2
Current driver: 319.17 (though I’ve tried it on 310.40 and 319.12 too)
UEFI

I originally posted this issue in the Arch Linux forums, because I wasn’t sure where the problem was (https://bbs.archlinux.org/viewtopic.php?id=162448). Now, I believe that it’s an Nvidia issue.

The problem:
Laptop functions normally, except, when I ctrl+alt+fX to a tty, all I get is a solid underscore cursor on a black screen and it never progresses from there. I’m using the efifb framebuffer. I can go back to my KDE session and everything is still fine. The other issue is that it won’t ever resume from sleep (I’ve tried systemd and pm-utils). There doesn’t seem to be any relevant info in the system logs (via journalctl). The laptop seems to start everything back up, including the screen backlight, but nothing is ever displayed – I also checked both external monitor connectors when this happens, in case it was trying to output elsewhere. I was able to ssh into it after resuming, so I know the system was at least mostly running.

The (temporary) solution:
In order to fix both of the issues, I just need to disable SLI in the xorg.conf (eg Option “SLI” “off”) or physically remove the 2nd card.

I’ve attached my journalctl log that includes an instance of not being able to resume (happens at May 19 17:09:13). Please let me know what other information would be useful in getting this resolved. Thanks.

journalctl http://dpaste.org/gXAiU/
nvidia-bug-report.log (not much there…) http://dpaste.org/sDrhe/

nvidia-bug-report (3).log.gz (114 KB)

Can you please attach the complete nvidia-bug-report.log.gz file? It’s produced by concatenating several smaller gzip files, which is a valid thing to do but some programs don’t handle it correctly.

I didn’t see a place to add attachments before, but I see there’s a button to do it after you’ve posted. I’ve attached the complete nvidia-bug-report.log.gz to my previous post. Please let me know if there’s anything else I can provide.

Updating thread to confirm that this is still happening on 319.23.

Thanks. Does this reproduce without UEFI enabled?

Thanks for the reply.

I’ve just confirmed that it still occurs in Legacy/BIOS mode (as opposed to UEFI mode). Seems to be the exact same behavior. Please let me know if there’s anything else that I can provide.

I’m running Gentoo, kernel is 3.12.13, and drivers 331.49. Did some research before I got this latop Lenovo y510p and never saw that mobile GPUs weren’t supported in SLI mode, I’ve got 2 750M. When I set SLI in the config file the X just went to a black screen, read about the SLI and mobile GPU issues shortly after.

Are you saying that you can get SLI to work?
Thanks
Cory

rage_311, I think you testing with 319* drivers , did you test with latest drivers 325* , 331*, 334* ?

ftp://download.nvidia.com/XFree86/Linux-x86_64/