[2 x SOLVED] Replaced ubuntu.desktop with xfce4 - No GUI - Login info Incorrect / Failing Lightdm Se

[Solution Later in Post] Preface:: This is an issue I had before now but just recently fixed and felt it would be worth mentioning. I am currently implementing a CPU/GPU heavy OpenCV algorithm onto the Jetson TK1 and I have been attempting/trying to tweak the Jetson as much as possible to get maximum performance. Because I require video to be displayed on the screen, I can not use a headless system so I attempted to switch over to XFCE which I read was more light weight than Ubuntu(I am using Grinch 19.3.8).

So installing XFCE was quite simple, I found a short and concise tutorial on this forum but it did not mention how to safely remove ubuntu.desktop to make a full transition to xfce without ubuntu residue all over. So after I installed xfce4, I attempted to remove ubuntu and gnome desktops using this code I found off some tutorial blog I found (originally intended for Ubuntu 14 to Xubuntu 14::::

sudo apt-get remove nautilus gnome-power-manager gnome-screensaver gnome-termina* gnome-pane* gnome-applet* gnome-bluetooth gnome-desktop* gnome-sessio* gnome-user* gnome-shell-common compiz compiz* unity unity* hud zeitgeist zeitgeist* python-zeitgeist libzeitgeist* activity-log-manager-common gnome-control-center gnome-screenshot overlay-scrollba* && sudo apt-get install xubuntu-community-wallpapers

Looking back on it this was a pretty careless move. So I tried restarting the Jetson to see if everything was okay and much to my dismay there was no GUI on boot. Looking at first glance I saw that lightdm was failing so I remained calm and hit CTRL ALT F1 and was brought to cmd line asking for login credentials.


So I attempted to enter username: ubuntu and password: ubuntu ; suprisingly this did not work. So I spent a couple hours scouring the internet on my other PC with a million tabs open with little to no solution. What I did observe was that the username was no showing up and it would register that I had pressed ENTER while typing in either the username or password. Very peculiar. Anyway I eventually found that after smashing a combination of CTRL+ALT+F1 , CTRL+ALT+F7 , CTRL + ALT + T and ENTER many times, I was eventually brought to a refreshed screen asking for the login info yet again. Buut, this time it worked correctly using USER: ubuntu and PWD: ubuntu . What I later found after a little trial and error, was that the successful combination once you have reached the initial login screen(ie after CTRL ALT F1) is to use CTRL+ALT+T and ENTER. I would recommend repeating a few times because it doesn’t work on the first try everytime due to that weird registering at that first login screen. Once I did this, I was brought to the root command line and using STARTX brought me to the xfce desktop, the sensation of feels rushed over me at 3:20am.

#Keep repeating this and try typing in a few letters occasionally,
#if you see anything besides Login/Password/Incorrect Login then it worked.



Next issue was figuring out how to fix the failing lightdm service.


First, I tried this and it did not fix the issue…

sudo /etc/init.d/lightdm stop

sudo dpkg-reconfigure xserver-xorg

I tried to look at the settings in /etc/lightdm/lightdm.conf and I found that I was missing lightdm.conf, so I created the file. This is the code I put in it:


Then I looked in /usr/share/xgreeters to verify the greeter file was there and the folder was empty. So I decided to use

sudo apt-get install lightdm-gtk-greeter

At some point I believe I created a file:: /etc/lightdm/lightdm.conf.d/xfce.conf unless it was already there I can’t remember. In this file I did::


And I believe that was it (I am not sure if all of these things were done in the EXACT order that I specify here but I think it is close), restart the Jetson and experience the same rush of feels I had or accept the challenge and begin your debugging quest of the night.


I am almost 100% sure that the first issue I encountered was very isolated and not very common but I can make risky mistakes occasionally… I might still have issues from the ubuntu/gnome removal I have not encountered yet but at least for now it does not feel like time is being wasted. Hopefully one of these solutions though will help out one of you guys/gals as I believe it could work similarly to some other distros X11, ie lxde, gnome, kde, etc. Cheers!