2019.4 installer requires older package?

I have VS2017 and VS2019 installed.
Is there another dependency?

Screenshot:
https://imgur.com/IUFe2UI

I had to uninstall the old 5.4 Nsight using MicrosoftProgram_Install_and_Uninstall.meta.diagcab

https://support.microsoft.com/en-us/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed