304.125, legacy GeForce-6 GPU: libnvidia-tls.so segfault when Adobe Reader starts

OS: Centos 7, kernel 3.10.0
GPU: GeForce 6 (6200 turbocache)

When i attempt launch adobe reader (and some other applications), they crash with segfault in libnvidia-tls.so.304.125:

acroread[20179]: segfault at ac5b9f43 ip 00000000f46ebcaa sp 00000000ffeaa738 error 4 in libnvidia-tls.so.304.125[f46eb000+3000]

I can’t install newer branches of nvidia driver - they don’t work with this GPU
I can’t downgrade driver - older branches aren’t support 3.10 kernel.

How to resolve this problem?

here is nvidia-bug-report: http://venus.ru/sm/nvidia-bug-report.log.gz
nvidia-bug-report.log.gz (54 KB)

Also, Mentor Expedition PCB (7.9.5) crashes with same symptoms in libnvidia-tls.so.304.125