[304.84] When switching from X session to tty{1,6}, display gets no signal

When i boot into system, everything is fine, tty’s are working.
After i start X (manually, i prefer to log into tty, then manually start X, if i need it) and then switch to tty, display gets no signal at all.
I had no problem with prior driver - 304.64, but today i upgraded to new one and downloaded some updates for my Slackware 14.0 distro (32bit).

If additional info needed, please tell me what you need. Thanks in advance.
nvidia-bug-report.log.gz (62.2 KB)

Boot with ‘vga=normal’ - it will fix your problem.

It did not for me; tty lasts longer, but after (hours…days) of uptime, the problem is back.

It didn’t. Still not working. Same result. Display is connected via DVI.

Hours? It’s not working even for a second. :|

…then you’re luckier than me in the sense that you can systematically reproduce the problem :)

Internally filed bug 1253539 to track this issue for G72/G73

I hope that fixing the issue for those chips will fix mine too, but please, take into account that my ttys are blank as well, and this is on a 9500GT and a 9800gt (the first dualhead, the second single one) and using both plain text consoles.
313.09 drivers.

Hello, I confirm this exact same issue but with nvidia 7900GS (G71) as well. When I try to switch to a VT[1…6] or when I exit X screen goes black. Somehow the state of the VTs does not get restored upon driver exit.

Driver version I am using is 304.84 for Linux

I am having the same problem on arch with agtx 580. I’m not sure if it means anything but when I disable my display manager (kdm) then there is no issue until I start the x server. However starting the xserver breaks everything. The only thing that gives visual output is the kdm and KDE desktop envirnment.

Blank tty screens here too after manually running startx. They are functional, I just can’t see them. All tty’s are visible until running X.
Card: Quadro FX 4000
Driver: 304.84-1
kernel: 3.8.3-2

nvidia-bug-report.log.gz (39.4 KB)

Same issue with blank screen when exiting from X.

GPU: GeForce 7600 GS
Driver: 304.84
Kernel: 3.8.3
Arch: x86_64

nvidia-bug-report.log.gz (61.4 KB)

shariebeth, kachelaqa, both of your bug report logs show the warning that occurs when your kernel is not properly configured to drive a VGA console:

I have the same warning too, actually.
So, there will be no fix, because it is not nVidia’s fault. Right?

Same issue here.
Considering this thread, I did some research and I came out with this “solution”. Adding the following to the kernel line:

video=vesa:off vga=normal

So now instead of having a blank tty, I have a big dash blinking on it. Still unusable. But, there are no

kernel: [   18.272960] NVRM: Your system is not currently configured to drive a VGA console
kernel: [   18.272967] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
kernel: [   18.272971] NVRM: requires the use of a text-mode VGA console. Use of other console
kernel: [   18.272974] NVRM: drivers including, but not limited to, vesafb, may result in
kernel: [   18.272976] NVRM: corruption and stability problems, and is not supported.

messages no more in my nvidia-bug-report.log, which used to be there.

OS: Arch x86
Kernel: 3.8.4-1-ARCH
Card: nVidia geForce 7025
Driver: nvidia-304xx 304.84-1

Including the bug report, which obviously includes the before and after kernel line boot change.

nvidia-bug-report.log.gz (68.2 KB)

Same issue here. In addition when I set resolution to 1440x900 (native) I’m getting bottom part of screen cut off. I have to use ‘auto’ to make it work. 304.64 works flawlessly so I’m sure it’s nvidia’s driver fault. However, the 304 series is legacy so they probably won’t fix it soon.

OS: Slackware x86
Kernel: 3.8.5
Card: geforce 7600 gs
Driver: nvidia-304.84

This was solved for me today with an update to version 304.88-1.

Thank you. That tip got me to the unity desktop. Under Ubuntu I activated version 173-updates (in ‘Additional Drivers’) and it now works properly without the additional switches.