[304.88] When switching to native (1440x900) resolution via nvidia settings, I get 1440x810 instead

When I set display to native resolution in nvidia settings panel, I get 1440x810 and the bottom of screen is cut off. However, when using ‘auto’ mode the problem doesn’t occur (It correctly sets resolution to 1440x900). The same was with 304.84 driver, 304.64 worked fine. It’s not a big deal, because as I said - ‘auto’ mode works.

When I use direct (1440x900) option Xorg.0.log says:

[  1019.637] (II) NVIDIA(0): Setting mode "DVI-I-1:nvidia-auto-select{ViewPortIn=1440x810,ViewPortOut=1440x810+0+45}"

‘auto’ option:

[  1138.661] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select@1440x900+0+0"

System: Slackware 32bit
Card: geforce 7600 gs
Driver: 304.88
Kernel: 3.8.5

Edit: OK, it IS a big deal. I just tried few games (using wine), they change resolution automatically but now launching them takes me back to login screen. I’m not sure if those issues are related in any way. 304.64 works OK though.

Edit2: Although issue with resolution changing still exists, I managed to solve the problem with wine games - default xorg.conf file generated by nvidia installer made the trick.
nvidia-bug-report.log.gz (57 KB)

Thanks for reporting this. I reproduced the problem and filed bug 1272909.

Bump - just in case it’s been forgotten.

The problem has been identified and should be fixed in the next 304.* legacy release.

It’s good to hear that. Thanks!