313.18, Xorg 1.12.3, 100% CPU usage

I don’t like vague bug reports but I tried my best to find any error message or anything but I am not finding them.

GPU: Geforce GTX 660 Ti

After installing 313.18 I noticed that the desktop became unresponsive for short (2-3 seconds) times when applications would open op progress bars where drawn, this happens for example when installing software with Yast2, as long as the install panel is up and the progression bars are moving de Desktop does not really respond to key/mouse and X.org is using 100% CPU

After playing a bit more around I noticed that the best and clearest way to show the behaviour was by opening the Opera web-browser with the speeddail (it has 16 dails on it), under 313.18 opening Opera takes about 25-30 seconds, it opens small, freezes, goes fullscreen mode, freezes, loads the dails, all the time X.org using 100% CPU

With 313.18 I can do this again and again and I would say 9/10 times this happens.
Under 310.19 this does not happen and Opera opens in about 3 seconds max

I turned of desktop effects (KDE) but it made no difference at all

nvidia-bug-report only gives:


Start of NVIDIA bug report log file. Please include this file, along
with a detailed description of your problem, when reporting a graphics
driver bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to ‘linux-bugs@nvidia.com’.

nvidia-bug-report.sh Version: 14583860

Date: Sun Jan 20 07:43:17 CET 2013
uname: Linux caladan 3.4.11-2.16-desktop #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux
command line flags:

X -version gives:

X.Org X Server 1.12.3
Release Date: 2012-07-09
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux caladan 3.4.11-2.16-desktop #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.4.11-2.16-desktop root=/dev/sda2 resume=/dev/disk/by-id/ata-WDC_WD5000AAKS-00D2B0_WD-WCASYA363695-part1 splash=silent quiet showopts vga=0x31a
Build Date: 08 January 2013 11:56:04AM

KDE version is 4.9.5

.xsession-errors holds nothing different compared to 310.19 in messages

-Xil

tired the 310.32 drivers which where released yesterday and they do not have the issues the 313 set has

hi

just small update

tried the 310.40 which work fine
tried the 313.26 and they show this issue also, so really seems to be something in the 313 series.

I upgraded to KDE 4.10.1 by now, also made no diffrence

is there anything else you need on info, I can try to record it so you see what happens if that is more clear then a description

Well another small update, although sadly no response from anybody

upgraded system to opensuse 12.3

same X -version: X.Org X Server 1.13.2
kde 4.10.0 and kde 4.10.2 and still the exact same issue with driver version 313 vs 310. xorg simply goes to 100% or over and desktop freezes for a few sec, still best reproduced when opening Opera with speeddail.

319.12 seems to have solved this issue :)