319.17 Driver no compile with kernel 3.10-2-486

I’m installing the NVIDIA driver for a laptop with gforce 8400M GS

With kernel 3.2.0-4-486, works good but with kernel 3.10-2-486 it doesn’t compile and the error in the log appears to be:

/tmp/selfgz5928/NVIDIA-Linux-x86-319.17/kernel/nv-i2c.c:327: error: void value not ignored as it ought to be
make[4]: *** [/tmp/selfgz5928/NVIDIA-Linux-x86-319.17/kernel/nv-i2c.o] Error 1
make[3]: *** [module/tmp/selfgz5928/NVIDIA-Linux-x86-319.17/kernel] Error 2
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.

The version from the download page is
NVIDIA-Linux-x86-319.17.run

What can i do?

Use 319.49 - see announcements.

Thanks, now it’s working.

I didn’t know this new release. They should put in the nvidia/download page