319.82 (WW) NVIDIA(0): Option "GLYield" is not used

I ran

nvidia-bug-report.sh

command, its output is here:http://pastebin.com/qNZvKrCV
I’d like to get working the options in

/etc/X11/xorg.conf.d/80-nvidia.conf

but X return:

[    12.503] (WW) NVIDIA(0): Option "GLYield" is not used
[    12.503] (WW) NVIDIA(0): Option "FSAAAppControlled" is not used
[    12.503] (WW) NVIDIA(0): Option "FSAAAppEnhanced" is not used
[    12.503] (WW) NVIDIA(0): Option "GLFSAAMode" is not used
[    12.503] (WW) NVIDIA(0): Option "GLThreadedOptimizations" is not used

In my

/etc/profile.d/local.sh

I had set these variable:

export KDE_TRIPLE_BUFFERING=1
export LD_LIBRARY_PATH="/lib/x86_64-linux-gnu/:/usr/lib/x86_64-linux-gnu/nvidia/current/"
export LD_PRELOAD="libpthread.so.0 libGL.so.1"

Why Nvidia driver doesn’t recognize those options? I red the documentation and they should be, what’s wrong in my setup?
Thanks for any answer.
Franco.

There not xorg options.
Use profile.d to export them instead

ftp://download.nvidia.com/XFree86/FreeBSD-x86/325.15/README/README.txt

Thanks for the answer leigh123linux, I did as you suggest but it doesn’t work, in my

/etc/profile.d/local.sh

now I’ve:

export KDE_TRIPLE_BUFFERING=1
export LD_LIBRARY_PATH="/lib/x86_64-linux-gnu/:/usr/lib/x86_64-linux-gnu/nvidia/current/"
export LD_PRELOAD="libpthread.so.0 libGL.so.1"
export __GL_YIELD="USLEEP"
export __GL_THREADED_OPTIMIZATIONS=1
export __GL_FSAA_MODE=7

but when I query for FSAA it return 0 I got:

~$ nvidia-settings --query=fsaa

  Attribute 'FSAA' (itek:0.0): 0.
    Valid values for 'FSAA' are: 0, 1, 5, 7, 8, 9, 10, 11, 12 and 14.
    'FSAA' can use the following target types: X Screen.

Talking about those xorg options in the first post surely I misunderstood how to use them. Those options are listed in appendix “J9. LIST OF SUPPORTED APPLICATION PROFILE SETTINGS” you can read about here: ftp://download.nvidia.com/XFree86/Linux-x86/319.82/README/README.txt how does the Nvidia driver to use them?

Hi there,
Have you looked at the “Application profiles” section in the nvidia-settings utility?
There’s a dropdown menu with these settings when you add a new profile.
Hope this helps.