325.15 drivers do not compile witth 3.11.1 kernel

Just got a kernel update from Fedora to 3.11.1-200.fc19.x86_64. Tried to install proprietary drivers and got a build error. anyone else have the same problem? if so, any known patches or do we have to wait for nvidia to issue a new set of drivers?

http://cvs.rpmfusion.org/viewvc/checkout/rpms/nvidia-kmod/devel/kernel_v3.11.patch?revision=1.2&root=nonfree

There was a change in linux-3.11.1/include/linux/mm.h that broke the 325.15 driver. It doesn’t look very hard to fix but I haven’t actually tried to, as I can live with linux-3.10.11 for the time being. Hope to see a driver update from NVidia before long; they’ve been fairly prompt at catching up to linux kernel changes…

The patch is easy

--- a/kernel/nv-linux.h
+++ b/kernel/nv-linux.h
@@ -957,7 +957,11 @@ static inline int nv_execute_on_all_cpus
 #endif
 
 #if !defined(NV_VMWARE)
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
+#define NV_NUM_PHYSPAGES                get_num_physpages()
+#else
 #define NV_NUM_PHYSPAGES                num_physpages
+#endif
 #define NV_GET_CURRENT_PROCESS()        current->tgid
 #define NV_IN_ATOMIC()                  in_atomic()
 #define NV_LOCAL_BH_DISABLE()           local_bh_disable()

Thanks ‘123’

Excuse me for being like an AMD fanboi but how duz yuz appliez itz …hoping for a reply before many failed attempts!!

sh NVIDIA-Linux-x86_64-325.15.run --apply-patch kernel_3.11.patch

This will work if you have drivar and a patch in a same directory, and if you named the patch file: kernel_3.11.patch

And if it askes you what file to patch, you just write this: kernel/nv-linux.h and press ENTER.

Here’s a cleaner patch

http://cvs.rpmfusion.org/viewvc/checkout/rpms/nvidia-kmod/devel/kernel_v3.11.patch?revision=1.1&root=nonfree

And on that bombshell…rejects.

After running the above quoted, you will get the following .run file;

running this will install quite ok.

Enjoy.

I removed NVIDIA CUDA toolkit, profiler or anything related to CUDA
and NVIDIA 325.15 installed without a hitch. Not sure if I really
needed CUDA but everything seems to be working fine. The only difference
is that my NVIDIA 325.15 came from ppa:xorg-edgers repository.

Wow, that patched .run file really is the business! merrily up and running again … thanks Marinus

I did the install of the 325.15-custom, and it does work for the most part. My problem is that my attempts to use the Adobe Acrobat reader fail.

As far as I can tell this is because the NVIDIA installer puts 64 bit binaries in the /lib directory, and the acrobat reader is a 32 bit binary. I had to re-install the mesa-libGL package and link it up to libGL.so.1 for things to work properly. Has anyone else had this problem?

Thanks.

Have you tried with the new NVIDIA 331.20 stable drivers?
https://devtalk.nvidia.com/default/topic/632611
This driver introduced the patch for Linux 3.11/3.12 by default.

I am running Fedora 19 and would like to install akmod-nvidia rpm. Current revision is 331.20-3.fc19
Has anybody tried to use the rpmrebuild tool to patch the driver? As the patch consists to add just four lines. Does anybody know if it would work and how to do it?