331,334,337 -> 3 monitors -> base mosaic -> fails to initialize DMA

I have been running two monitors with no problems for a while and picked up a 3rd when it went on sale today. Ive been trying to make it work for the past 4 hours. Xinerama works… but with its limitations of course. I use conky and not being able to use double buffer it flickers really bad and I cant have that. I can make monitor 1 & 2 work as screen0 and monitor 3 work as screen1… but that sucks too =P Monitors 1 & 2 are on gpu0 and monitor 3 is on gpu1

I don’t know if I’m just not googling the right thing… but anything I have come up with has not worked. I am using Xububtu 14.04 (x64) with 2 EVGA GTX580 SC 1.5gb cards and 3 AOC I2757FH 1080p monitors all connected with DVI->HDMI cables. I have tried various drivers (331-340) manually installed and the ones in ubuntu’s repos and all spit out the same “error”. I can completely configure what “should” work using the nvidia-settings gui no problem… it just wont start.

the attachment below has the output of nvidia-bug-report.sh. I also added in my Xorg.0.log of it falling on its face and a xorg.conf (that nvidia-settings made).

nvidia.tar.gz (157 KB)

Just found the following post… likely the same exact issue. Is it possible that it has something to do with XFCE as we are both using it? Im going to try some other flavors and see what happens.

https://devtalk.nvidia.com/default/topic/657997/linux/cannot-start-x-on-archlinux-3-12-3-and-with-driver-331-20-2-while-sli-and-basemosaic-are-enabled-/1/

Been too busy playing video games with this sweet surround setup in windows the past couple of days but I decided to try again with a clear head and it worked! I have base mosaic working just fine finally! Based on things I read and the DMA error I was getting everything pointed to iommu. The simple fix ended up being adding “iommu=pt iommu=1” to the kernel arguments. It booted up no problem and I setup the base mosaic using the nvidia-settings gui… saved to a clean xorg.conf… restarted lightdm and crossed my fingers. The standby lights went off on the other two monitors and I was met with a 5760x1080 XFCE desktop that works! Compositing is working and conky no longer flashes.