340.104 & 340.106 driver issue in Linux Mint 18.3 Cinnamon on MacBook Pro 15" Core i7 mid-2010 with GeForce GT-330M

Hi,

When I install this and open Driver Manager, the screen goes black, cooling start to spin loud and the only thing I can do is power off. I wanted to install this driver again to run nvidia-bug-report but when I did so, this time there was a black screen already - I’s able to log in “without seeing things” and ran nvidia-bug-report.sh although I don’t know if it’s of any use in that case. I had this issue also in Linux Mint 18.2 Cinnamon & KDE.

nvidia-bug-report log: https://www.sendspace.com/file/4h4073

TIA
Mark

The kernel driver is still 304.137, so it doesn’t work. It might suffice to issue
sudo update-initramfs
and reboot. If not, purge and reinstall the driver.

Are you trying to nuke my topic?

Anyway, I’m sending nvidia-bug log after installing nVidia driver, 100% that’s the one, mentioned issue happening again: https://www.sendspace.com/file/f0n557.

Mark

The driver is now running fine, an Xserver is coming up.
Now you’re hitting the next problem, this is a dual gpu system but not the standard Optimus but a proprietary Apple errm…Applemus. I suspect the Xserver is running on the nvidia but the display is still switched to the intel.
I don’t know if the standard Prime works on Apple or if you have to use the apple_gmux driver to use vgaswitcheroo to switch graphics.
To test standard Prime, you’d need to install packages
nvidia-prime
ubuntu-drivers-common
then you should be able to use prime-select intel/nvidia to switch.
If that doesn’t work, use apple_gmux+vgaswitcheroo
https://github.com/ah-/gmux
https://github.com/ah-/gmux-scripts

For now I don’t know how to do that, so let’s say i want to use just nvidia, the issue is that when i run OpenGL app immediately the screen goes black, fans begin to spin loud, keyboard lightning is max and i can only power off. I checked with 4.4, 4.6, 4.8 & 4.10 kernel, Mint 18.3 & 17.3 (also with these kerns). I tried a bit with this gmux, there’s apple_gmux loaded on both Mints so i didn’t compile the external one, dual gfx through bumbleblee wasn’t working, i tried with switcheroo and using bumbleblee config from gmux-scripts, there’s no vgaswitcheroo in /sys/kernel/debug anyway…

See this:
https://askubuntu.com/questions/264247/proprietary-nvidia-drivers-with-efi-on-mac-to-prevent-overheating/613573#613573

Here’s the same for your specific model
https://freedompenguin.com/articles/how-to/installing-ubuntu-mate-macbook-pro-uefi/

Has anyone had any luck dealing with this issue?

I have no idea how to even start troubleshooting, as from the software side everything seems to be working…

Your best luck will be to abandon this futile idea. When you were buying a MacBook you perfectly knew what you were getting - a very special piece of x86 hardware which only works well with MacOS X.

Even though BootCamp exists, Windows on MacBooks is an absolute PITA. And I don’t even want to talk about MacBook keyboards. This is just a pure unusable abomination even when you’re working in MacOS X.

PgUp/PgDn/Home/End are missing and can only be used via Fn.

Delete is backspace with Fn.

Insert is missing.

Alts/Ctrls/Shifts all work in a very peculiar manner. No PrtScr/SysRq/Pause either.

Problem is, that every iteration of MacBookPro/Air with switchable nvidia graphics used a different, Apple-proprietary switching method. Some can be made to work on linux, some sometimes, others not without booting to OSX. So whether a solution exists or not depends on the exact model.

Thanks, mine is the fall 2012 retina, I will look for solutions for this specific model then!