340.17/337.xx [GTX 750 Ti] - random glitches when minimizing OpenGL-accelerated applications

A week ago I bought new GTX 750 Ti and decided to upgrade to LTS release of Linux Mint - LM17 with MATE desktop environment. So I did a clean installation, and installed latest stable at the moment driver, 337.25.

Initially, I thought that everything went fine. Then I installed Chrome, Steam and gave them a whirl. Acceleration worked fine (direct rendering kicked in), but every time I tried to minimize active window of the app that used acceleration at that time, I got chunks of “accelerated” area (for instance, video area, in case with VLC) still on top, despite the fact that window was, in fact, minimized.

The same happens with Chrome, Steam, well, everything that uses GPU for hardware acceleration.
I thought that it was initial release’ issue, and then tried to install beta verion, 340.17. Nothing changed at all.

I was unable to make a screenshot of this or capture a video, so I did it with my smartphone: www.youtube.com/watch?v=9Kw8Kcy_uvc.

While I was googling this issue, I stumbled upon this thread at Ubuntu’s Launchpad (link) which pretty much described these glitches. The only difference is that guys there think that it’s Compiz issue. But as far as I know, MATE version of Mint doesn’t have it.

Once again, I’m running 64-bit version of Linux Mint 17 [MATE], b\w GTX 750 Ti & at the moment, beta-version of proprietary driver (340.17). If necessary, I’m ready to provide additional info.

Thank you for your time.

Well, this is so like NVIDIA.

You buy 200$ accelerator and despite all this hogwash about making better drivers for Linux, there’s still no support, just like five years ago. That’s why there’s so little decent games on *nix, not because of the “chicken and the egg” problem.

Which version of the X server are you running? I just tracked down an interaction problem with a change in xserver 1.15 that could cause similiar corruption to this. The fix should be available in the next release.

I’m running X.org v1.15.1 - stock version for LM17.

Aaron, how soon can we expect a new driver’s release with this issue resolved?
This issue forced me to switch to XFCE, which I sincerely loathe, and I’d like to get back to MATE asap.

Can you please give 331.89 a try and see whether it solves the problem for you?

I confirm, all glitches are gone now. Everything is working the way it supposed to.
Thank you!

thanks, i just found this thread and it was very helpful.

additionally i would like to add that the BETA 343.13 drivers still have this issue just in case anyone is wondering as i tried to upgrade from 340 first before going to 331.

edit:
also…my card is a 560Ti.
same problem though.

just wanted to pop back in here and say i have successfully updated to 346.22 without having issues.

originally 346.22 was also giving me issues with flickering. i found that this was in fact an issue with GNOME desktop. this only happened because GNOME refused to cooperate when i did a reinstall on my system one day and switched to KDE. initially i installed the 331.89 and all was good. then i recently i decided to see if 346.22 was working since i changed things… and it worked!

so ya… dunno what was going on with GNOME there, but KDE seems to not be having the issue.