(35 vs. 0) CUDA driver version is insufficient for CUDA runtime version

Hi
I’m trying to install Caffe on ubuntu 16.04 with a GTX 960M.
I have CUDA 8.0 and i manually installed the latest nvidia driver prior to that.
However, i get the error message
(35 vs. 0) CUDA driver version is insufficient for CUDA runtime version
Please Help.
Regards