355.11 driver - kwin_x11 fails to enable compositing with EGL

When, in the KWin compositor settings, I switch the OpenGL Interface to “EGL”, with either “OpenGL 2.0” or “OpenGL 3.1” set and click apply, I get this output from the terminal:

OpenGL vendor string:
OpenGL renderer string:
OpenGL version string:
OpenGL shading language version string:
Driver:                                 Unknown
Driver version:                         0.354.33632
GPU class:                              Unknown
OpenGL version:                         0.0
GLSL version:                           0.0
X server version:                       1.16.4
Linux kernel version:                   4.1.6
Requires strict binding:                yes
GLSL shaders:                           yes
Texture NPOT support:                   no
Virtual Machine:                        no
kwin_core: Failed to initialize compositing, compositing disabled

Examining the KWin Git code with v5.4.0 checked-out, from line 268 in composite.cpp, found at https://quickgit.kde.org/?p=kwin.git&a=blob&h=1db4790b50d99401c175e90852f5e4958f53fc8c&hb=a97b6e0fd6a5eff53e3fccff825998feb4026a34&f=composite.cpp, shows:

if (m_scene == NULL || m_scene->initFailed()) {
        qCCritical(KWIN_CORE) << "Failed to initialize compositing, compositing disabled";

I hope this helps, somehow. Please ask you need additional information. :)

Do you actually have EGL libs installed? E.g.:

/usr/lib$ ll libEGL*
-rwxr-xr-x 1 root root 939336 Aug 31 19:51 libEGL_nvidia.so.0
lrwxrwxrwx 1 root root     11 Aug 31 19:51 libEGL.so -> libEGL.so.1
lrwxrwxrwx 1 root root     15 Aug 31 19:51 libEGL.so.1 -> libEGL.so.1.0.0
-rwxr-xr-x 1 root root 156448 Jul 12 12:34 libEGL.so.1.0.0

The above is actually linking to mesa’s EGL, rather than Nvidia’s.

Yes, it is linking to Nvidia’s EGL implementation.

When I run “ls -l libEGL*”, I get this output:

lrwxrwxrwx 1 root root     18 Sep  1 07:25 libEGL_nvidia.so -> libEGL_nvidia.so.0
-rwxr-xr-x 1 root root 939336 Sep  1 07:25 libEGL_nvidia.so.0
lrwxrwxrwx 1 root root     11 Sep  1 07:25 libEGL.so -> libEGL.so.1
lrwxrwxrwx 1 root root     27 Sep  1 07:25 libEGL.so.1 -> /usr/lib/nvidia/libEGL.so.1
lrwxrwxrwx 1 root root     11 Sep  3 00:46 libEGL.so.1.0.0 -> libEGL.so.1
lrwxrwxrwx 1 root root     11 Sep  1 07:25 libEGL.so.355.11 -> libEGL.so.1

There are also these relevant Nvidia libraries

lrwxrwxrwx 1 root root       27 Sep  1 07:25 libnvidia-eglcore.so -> libnvidia-eglcore.so.355.11
-rwxr-xr-x 1 root root 25131784 Sep  1 07:25 libnvidia-eglcore.so.355.11
lrwxrwxrwx 1 root root       23 Aug 22 09:59 libwayland-egl.so -> libwayland-egl.so.1.0.0
lrwxrwxrwx 1 root root       23 Aug 22 09:59 libwayland-egl.so.1 -> libwayland-egl.so.1.0.0
-rwxr-xr-x 1 root root     6032 Aug 22 09:59 libwayland-egl.so.1.0.0

Interestingly, for the driver version string, its value always seems to change when I switch back to GLX and back again to EGL. I have so far gotten values ranging from 0.0, 0.788.53488, 1076428800.0.1, 1076428800.0.18, 355.11, et cetera, which makes me wonder where those values are coming from, for a start.

That would explain the tearing I had when I tried the EGL backend in Kwin.

Comopositing and desktop effects don’t work for me with latest Nvidia beta (358.09) when I choose EGL instead of GLX in KDE settings (kwin-x11, KDE Plasma 5.4.2).

Just installed 358.16. It still doesn’t work with KWin in EGL mode.

Same exact issue here since 355.11. One weird thing is that the eglgears_x11 sample from mesa-demos creates a black/empty window and while no error is displayed, nothing gets rendered in it.


Bump latest WHQL 352.63 still do not enables composting EGL mode in Manjaro Linux 15.12 x64 kde 5.5 plasma 5.5



yes it is not exposing EGL support in 352.16 WHQL and just turning off effects on MANJARO 15.12 or OPENSUSE leap 42.1

i too observe black screen in eglgears on 358.16

is egl even supposed to work with nvidia blob?

The problem still exists in 361.28. Is EGL really supported or not?

Still broken with 364.12, even though the driver claims even better EGL (and Wayland!) support.

The QT libs and kwin have to have OpenGL ES support built in. Standard OpenGL with EGL doesn’t expose the correct extensions.

any workground for this?

same fail in 370.xx

I thought kwin already dropped EGL for being too buggy:

Or is there some other program which shows nvidia’s implementation is broken?