355.11 Dual Monitor setup

Hi,

Using x11-drivers/nvidia-drivers-355.11 breaks my setup. under Gentoo Linux.

Primary monitor is an HP w2207h (1680x1050)
Secondary Monitor is an Pavilion 22xi (1920x1080)

Staring KDE with the mentioned nvidia driver, the display on the primary monitor is shown wrong. I have a black border on the left which is about 1/6 of the screen (it looks squeezed).
The primary display is distorted, secondary is displayed fine.
Checking under X Server Display Configuration with nvidia-settings shows the correct values (1680x1050) and (1920x1080).

GFX Card is a GeForce GTX 660

cat xorg.conf

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 352.30 (buildmeister@swio-display-x64-rhel04-18) Tue Jul 21 19:35:20 PDT 2015

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “InputDevice”
# generated from data in “/etc/conf.d/gpm”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “IMPS/2”
Option “Device” “/dev/input/mouse0”
Option “Emulate3Buttons” “no”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “Monitor”
# HorizSync source: edid, VertRefresh source: edid
Identifier “Monitor0”
VendorName “Unknown”
ModelName “HP w2207”
HorizSync 24.0 - 83.0
VertRefresh 48.0 - 76.0
Option “DPMS”
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTX 660”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “CRT-0”
Option “metamodes” “DVI-I-0: nvidia-auto-select +0+0, DVI-D-0: nvidia-auto-select +1680+0”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24
EndSubSection
EndSection

Switching back to x11-drivers/nvidia-drivers-352.41 solves the problem.

Have you considered chucking xorg.conf entirely and letting xrandr configure automatically?

Hi Linubie,

it seems you are not alone: https://devtalk.nvidia.com/default/topic/881804/linux/not-alone-vga-dvi-issue-on-355-11-linux-driver-/?offset=2#4684226