364.12 - GTX 580 - kmscon doesn't use native resolution to fill screen

Hi,

to get a better VT I installed kmscon on Arch Linux. When I launch it from a TTY “sudo kmscon --hwaccel” the console that is started only takes up a small part of the screen and keyboard input feels very slow.

You can see a comparison with the nouveau driver here:

http://imgur.com/a/3e2s0

With nouveau the kms console is very fast and fills the whole screen.

‘hwaccel’ option do not work with 364.12, nvidia driver don’t have gbm support yet. I think kmscon treat /dev/fb0 as one of the display device whose size of 640x480, and therefore it only takes up a small part of the screen which is visible on all (drm and fbdev) displays.