364.12 - GTX 580 - mpv --vo=opengl in weston shows old framebuffer fragments survives reboot

Hi,

this is the strangest bug I have found so far. In weston I played some Xonotic with “SDL_VIDEODRIVER=wayland xonotic-sdl”, which works fine. I exited xonotic at some point and wanted to test mpv on Wayland with the patched weston. So I started epiphany and downloaded Big Buck Bunny and tried to play it with “mpv --vo=opengl thevideofile.mp4”. Instead of playing the video I saw some leftover fragments from Xonotic. I rebooted with “sudo reboot” and tried again thinking that everything should be flushed now, but again I saw parts of Xonotic.

Here is a comparison with nouveau, which correctly starts playing the video.

http://imgur.com/a/bfB0s

With the --vo=drm option both drivers (nvidia and nouveau) play the video directly on the TTY with the same end result.

EDIT: I switched to nouveau and back and started into Gnome 3.20 and wanted to find out if I can still get the Xonotic fragments. So I rebooted and appended “3” to my kernel line which boots directly to VT. I logged into my TTY and started weston --use-egldevice. I tried to play the video again, now I see something different. I don’t know what these symbols are, because I have never seen them on my screen. They appear every time I reboot and try to reproduce this.

http://imgur.com/LxQVb3h