381.09 and Ubuntu 16.04 resume from suspend.

Regarding: 381.09

Appears stable until a resume from suspend.

Some moments (seconds, minutes) after a resume from suspend the system becomes unresponsive for a few minutes (~2 minutes).

After that it appears to be stable.

System:

Linux-x86_64 4.4.0-66-generic
GeForce GTX 1060 6GB (86.06.39.00.60)
Intel® Core™ i7-7700K CPU @ 4.20GHz × 8 (32G Ram)
Ubuntu 16.04.2 LTS
Dual monitors (Display Port)
ASUS PRIME Z270-A LGA1151 (BIOS: 0906)

What are these processes?

PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                                                   
 1064 root     -51   0       0      0      0 S   0.7  0.0   7:18.96 [irq/134-nvidia]                                                          
18227 root      20   0       0      0      0 S   0.0  0.0   0:00.00 [nvidia]

While the system is temporarily “hung” the

irq/134-nvidia

process is the top process.

dmesg:

[26359.644624] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:0:0
[26361.644761] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:1:0
[26363.645145] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:0:0
[26365.645282] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:1:0
[26365.645847] NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000000 00000080 00000000 00000005 00002021
[26397.820974] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:0:0
[26399.821116] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:1:0
[26401.824376] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:0:0
[26403.824513] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:1:0
[26403.864317] NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000001 00000094 00010077 00000007 00000000
[26403.864325] NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000002 00000094 00010077 00000007 00000000
[26403.864527] NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000001 000000c0 00010079 00000007 00000000
[26403.864533] NVRM: Xid (PCI:0000:01:00): 56, CMDre 00000002 000000c0 00010079 00000007 00000000
[26459.932902] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:0:0
[26461.932851] nvidia-modeset: ERROR: GPU:0: Idling display engine timed out: 0x0000927c:1:0
[26470.622303] compiz[15801]: segfault at 0 ip 00007f647338dab9 sp 00007ffda0fc0a48 error 6 in libnvidia-glcore.so.381.09[7f647217b000+145a000]
[26473.046290] compiz[18742]: segfault at 0 ip 00007fe88b3bd2ab sp 00007ffd686fd110 error 6 in libnvidia-glcore.so.381.09[7fe88a17b000+145a000]
[26475.577685] compiz[18769]: segfault at 0 ip 00007f8efd8092ab sp 00007fffe4138960 error 6 in libnvidia-glcore.so.381.09[7f8efc5c7000+145a000]
[26478.056131] compiz[18790]: segfault at 0 ip 00007f3385e402ab sp 00007ffeec3a37c0 error 6 in libnvidia-glcore.so.381.09[7f3384bfe000+145a000]
[26480.559546] compiz[18811]: segfault at 0 ip 00007f503a6cf2ab sp 00007ffe0e3ea750 error 6 in libnvidia-glcore.so.381.09[7f503948d000+145a000]
[26483.136952] compiz[18833]: segfault at 0 ip 00007f60933bd2ab sp 00007fffe3443140 error 6 in libnvidia-glcore.so.381.09[7f609217b000+145a000]
[26485.722386] compiz[18854]: segfault at 0 ip 00007f10473bd2ab sp 00007ffe6af20c70 error 6 in libnvidia-glcore.so.381.09[7f104617b000+145a000]
[26488.187131] compiz[18876]: segfault at 0 ip 00007f05fb3bd2ab sp 00007ffe9b3c0540 error 6 in libnvidia-glcore.so.381.09[7f05fa17b000+145a000]
[26490.577935] compiz[18898]: segfault at 0 ip 00007fdaa9a222ab sp 00007ffecd0188c0 error 6 in libnvidia-glcore.so.381.09[7fdaa87e0000+145a000]
[26493.052133] compiz[18921]: segfault at 0 ip 00007f585f3bd2ab sp 00007ffc90ada080 error 6 in libnvidia-glcore.so.381.09[7f585e17b000+145a000]

Thank you for reading,
Adam.

RE: 381.22

Appears to work.

Congratulations and thank you for continuing to support your products.

Please, do not break “suspend” again. It’s kind of important.