[390.25] Random flicker in mid screen when deskop is mostly idle/empty.

@Aaron, please keep us updated with any information you may need from us to reproduce or diagnose this bug. Thanks again.

I am encountering this issue on Linux Mint Cinnamon 18.3, using NVidia 387.34, but it’s only visible in recorded videos (such as this one: https://www.youtube.com/watch?v=uBUWIkd9Evw).

I usually record videos on my second screen, so I can’t say for sure whether it’s also happening on my main screen.

Using different codecs for recording didn’t change the issue.

After checking out this thread, I turned on “Force Full Composition Pipeline” and recorded another video just now. The issue seems to have disappeared, but of course it will require some more observation to be sure.

Graphics card: Gigabyte GeForce GTX 970
OS: Linux Mint Cinnamon 18.3
CPU: Intel I7 4790k
RAM: 32 GB

your issue is totally different and not the same reported here. Its the framerate difference from your recording and compositing and monitor that will do this when no ForceComposition is enabled.

This bugreport is for 390.x drivers and the issue happens when ForceCompositionPipline is enabled.

I just upgraded my Arch Linux desktop to kernel Linux 4.15.1-2-ARCH #1 SMP Sun Feb 4 22:27:45 UTC 2018 x86_64 GNU/Linux and nvidia 390.25-4 and am experiencing the same full screen flickering issues.

Using KDE5 Plasma.

Graphics card is Asus STRIX-GTX1080TI-O11G-GAMING.

I’m only noticing the flickering on one of my two monitors. An Asus 1440p 144hz monitor. It is set to primary display, I’ve tried force full compositing pipeline, and sync is set specifically to that display. I have not noticed any flickering on my secondary 1440p 60hz monitor.

It feels like the flickering is exacerbated by chromium. Sometimes when it flickers it will act up a lot of times close together. Sometimes when I mouse over certain ui elements (the closing x box in the top right of chromium) I would see a triangular region flicker black rather than the whole screen.

No known graphical issues on 387.34.

This still happens with 390.30 from the graphic-drivers CUDA repo and kernel 4.15.0.

390.30?

There does not seem to be any indication of 390.30 in the graphics-drivers PPA at https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa nor do I see it released by nvidia.

That’ll teach me to just assume things.

It actually came from the CUDA repo. Sorry about that!

https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64/

Same here with Arch Linux and KDE. My video card is GTX 1080Ti. I don’t use Chrome/Chromium.

I’m experiencing what I believe is the same issue on Arch Linux running the latest KDE version. I have 3 monitors, 1 on HDMI and two on DisplayPort. Only the DP monitors have flickering, and it seems to occur regardless of enabled/disabling any combination of nvidia-settings composition settings and the KDE provided Compositor. Started immediately after updating to 390.25 and the latest kernel.

Mine seems to get the worst when using Vivaldi, but the flickering still occurs regularly with other applications running including the Brave browser and general desktop use. Interestingly the flicking continues to happen on my auxiliary DP monitor while playing fullscreen games on my main DP monitor, but with no flicking on the main monitor while in game.

Lastly while the flickering always happens when using the machine, occasionally it gets so bad that it triggers errors in KDE that cause the DE to stop refreshing/updating, i.e. the clock doesn’t change and new/closed programs don’t visually reflect on the taskbar.

Not sure if all that helps but if there’s anything else I can provide I’d be happy to.

@aplattner - Is there any update on this issue? I have seen a few driver updates, but this issue still exists. I am hoping this will be resolved soon, and would like to get an update.

Yes the problem is still here and it’s annoying…

This display composition flicker should be fixed in the next release.

Aaron, if possible, please make sure this fix and the one for the ‘swap resume’ warning make it to 390.xx branch and not only future major driver releases such as 393, or 395, etc…
Thank you.

I notice occasional flickers, too, when idling in the desktop. I’m using XFCE with compositing disabled.

With 390.42 there’s no flickering any more. Thank you :)

I still have flickering on the desktop with 390.48, but the flickers on the windows seem to be gone, though.

Linux Mint 18.3 x64
Cinnamon 3.6.7
Nvidia GTX 1080

I too have flickering black box on random area of the screen with 390.48

Linux Mint 18.3
Cinnamon 3.6.7

for me, nvidia has brought back the awesome blink tag. See how the screen flashes black as the cursor blinks (in Chrome, this was 390.48).

try new 396.18 beta drivers if you can.

weird though as for me 390.48 fixed everything, no flickering

and no flickering on the 396.18 beta drivers either