3D stereo on linux doesn't work

Hello,

I try to have 3D on linux since few weeks without any success. I think I have tried anything I have found on the web. I hope there is some kind people with an idea to help me in this situation, I need it for my work.

  • OS: Linux, Ubuntu 13.10 under XFCE (I have first try gnome-shell but it need composite which should be disabled for enabling stereo. Then I've tried Unity but it seems there is some problem with compiz too so I have moved on XFCE
  • Graphic card: Quadro K4000. I have added a 3 pin mini-DIN because I have red it is needed (unless if it is indicated as "optional" on NVIDIA official webiste...)
  • Glasses: NVIDIA vision 2 with IR transmetter pluged with USB and mini-DIN. Light is green but not bright green as it should be. I have 2 different glasses, fully charged. Both doesn't work.
  • Screen: BenQ XL2720T, which is compatible with NVIDIA 3D vision 2 (120Hz). The green "3d" Light on the screen is working when stereo option is set as "10" in xorg.
  • Xorg: Stereo option 10 and composite disabled. I have tried a LOT of configuration without any success. You can see my xorg at the bottom of the post
  • NVIDIA Driver: The last one for Quadro on Linux, version 334.21 (released last week)

Actual situation

  • IR transmetter is green (but not bright green)
  • Screen seems to work at 120Hz
  • glxgears -stereo works but with an extrem ghosting. When I wear glasses, I see the ghosting but no 3D effect. In fact, no difference when I wear or not the glasses…

CONCLUSION: I think glasses do not synchronize with the IR transmetter. However I find no solution. Please do not hesitate to give your feeback if you are/were in the same situation.
I hope we would find a solution quickly.

An answer from NVIDIA support team would be really great!
Thanks you for your help.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 334.21  (buildmeister@swio-display-x64-rhel04-16)  Thu Feb 27 14:37:03 PST 2014

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 334.21  (buildmeister@swio-display-x64-rhel04-16)  Thu Feb 27 14:36:51 PST 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "BenQ XL2720T"
    HorizSync       30.0 - 140.0
    VertRefresh     56.0 - 120.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K4000"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "10"
    Option         "UBB" "1"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "1920x1080_120 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    Option         "ForceStereoFlipping" "True"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection

Plz provide nvidia bug report by running nvidia-bug-report.sh script as root user. Did stereo ever worked in your setup? Also did you test with any other drivers from ftp://download.nvidia.com/XFree86/Linux-x86_64/ ?

Hello,

Thanks for your reply.
You can download my Nvidia bug report here

I have tried at least 4 different drivers, the 2 last and older ones but I do not remember versions…

I hope this could help.

Hello,

Any idea ?
Please do not hesitate if you could help me (and others in same situation).
Thanks in advance.

Hello,

The problem is solved, there was a contact failure between the Quadro card and the additional stereo connector.

By the way, I confirm that stereo connector (with 3pin mini-DIN) is NOT optionnal on Linux systems.