404 error.Unable to download

Please provide the following information when requesting support.

Hardware - GPU (T4)
Operating System:Ubuntu, 20.04 LTS
Riva Version:2.6.0
TLT Version (if relevant)
How to reproduce the issue ? (
1.)Run below NGC command
2.)ngc registry resource download-version “nvidia/riva/riva_quickstart:2.6.0”
3.)The following error occurs
Getting files to download…
⠴ ━━━━━━━━━━━ • 0.0/105.5 • Remaining: -:–:-- • ? • Elapsed: 0:00:00 • Total: 18 - Completed: 0 - Failed: 0
Error getting pagination for file download:'{“timestamp”:1686821936861,“status”:404,“error”:“Not Found”,"path
⠴ ━━━━━━━━━━━ • 0.0/105.5 • Remaining: -:–:-- • ? • Elapsed: 0:00:00 • Total: 18 - Completed: 0 - Failed: 0

Download status: FAILED
Downloaded local path resource: /home/sunilkumarred_chilu/riva_quickstart_v2.6.0
Total files downloaded: 0
Total transferred: 0 B
Started at: 2023-06-15 09:38:56
Completed at: 2023-06-15 09:38:56
Duration taken: 0s


please guide to resolve this issue

Same to me on mac m1:

ngc registry resource download-version “nvidia/riva/riva_quickstart:2.11.0”

Error getting pagination for file download:‘{“timestamp”:1686943143724,“status”:404,“error”:“Not Found”,“path”:“/v1/org/nvidia/team/riva/resources/riva_quickstart/2.11.0/files”}’
“download_end”: “2023-06-16 21:19:03”,
“download_start”: “2023-06-16 21:19:02”,
“download_time”: “1s”,
“files_downloaded”: 0,
“local_path”: “/Users/DEV/Python/NVIDIA/Riva/riva_quickstart_v2.11.0”,
“size_downloaded”: “0 B”,
“status”: “FAILED”

but after researching a bit I have manually found the URL: Riva Skills Quick Start | NVIDIA NGC

and also figured out that the actual resource path should be: /v2/resources/nvidia/riva/riva_quickstart/versions/2.11.0/files/ instead of “/v1/org/nvidia/team/riva/resources/riva_quickstart/2.11.0/files” but no idea how to change that for the “ngc registry download-version” command. It seems it is on the NGC backend side

Had the same issue on Win 10. Any success to resolve it?

Apparently, we have to wait for that to be fixed in the “ngc registry download-version” command or download files manually otherwise

Cannot download manually too

bump for same problem with maxine:

ngc registry resource download-version "nvidia/maxine/maxine_windows_ar_sdk_ga:0.8.2"

and no apparent way to download manually via the website either. it’s all broken

1 Like

If you visit the catalog with your browser.

You will find ‘…’ next to each file where you can choose between copying a terminal command for downloading or downloading the file right in your browser.

I have created a simple bash script to make it all at once and it worked for me (see attached file)
download-version.sh (3.4 KB)

Just replace second line in the .sh file to the actual folder you want to use

Catalog is here:

Thanks for the script.I tried downloading the files with the script.

However I am unable to initialize and start the riva scripts.
riva_init.sh: line 1: {requestStatus:statusCode:FORBIDDEN}: command not found

Yep, same to me, unfortunately, the error is just written inside each downloaded file. Apparently, we’re out of options for now and have to wait while it is fixed by the NVIDIA team

Any update on this? I’m having the same problem. Seems like the riva scripts have not been downloadable for a week or more.

1 Like

Same here; albeit with a different package nvidia/maxine/maxine_windows_ar_sdk_ga:0.8.2" UK, Windows 10.
Apologies if not the right place to bump, but I assume its not package specific, and as such this looks like a decent home for my post!
Download on the website:

7754-364d819a9639baf0.js:1     GET https://api.ngc.nvidia.com/v2/resources/org/nvidia/team/maxine/maxine_windows_ar_sdk_ga/0.8.2/files?path=NVIDIA%20AR%20SDK_0.8.2.0.zip 403

(anonymous) @ 7754-364d819a9639baf0.js:1

Xt @ framework-79bce4a3a540b080.js:1
_app-6d007a8c2ffb9c1b.js:132 Error: Not accessible to guests
    at 7754-364d819a9639baf0.js:1:10109
    at s (main-ce961771177316e0.js:1:102475)
    at Generator._invoke (main-ce961771177316e0.js:1:102263)
    at forEach.e.<computed> [as next] (main-ce961771177316e0.js:1:102898)
    at r (_app-6d007a8c2ffb9c1b.js:132:680055)
    at u (_app-6d007a8c2ffb9c1b.js:132:680258)

Attempt with ngc

Cally@CallyDesktop MINGW64 /f/dev
$ ngc registry resource download-version "nvidia/maxine/maxine_windows_ar_sdk_ga:0.8.2"

Error getting pagination for file download:'{"timestamp":1687293093633,"status":404,"error":"Not Found","path":"/v1/org/nvidia/team/maxine/resources/maxine_windows_ar_sdk_ga/0.8.2/files"}'
    "download_end": "2023-06-20 21:31:34",
    "download_start": "2023-06-20 21:31:33",
    "download_time": "0s",
    "files_downloaded": 0,
    "local_path": "F:\\dev\\maxine_windows_ar_sdk_ga_v0.8.2",
    "size_downloaded": "0 B",
    "status": "FAILED"

As a side note, my original attempt with NGC ended up with this:

Cally@CallyDesktop MINGW64 /f/dev
$ ngc registry resource download-version "nvidia/maxine/maxine_windows_ar_sdk_ga:0.8.2"
Getting files to download...
'charmap' codec can't encode character '\u280b' in position 0: character maps to <undefined>

I assumed a unicode issue, and shifted the ngc config over to JSON to get slightly further along :)
Looking forward to getting access!!!

1 Like

Downgrading to CLI version 3.22.0 is a workaround. You can use the command ‘ngc version upgrade 3.22.0’

1 Like

This workaround has actually worked. I am able to proceed furthur :-)
Thank you so much…

It worked for me as well. Thank you for that