435.21 (Prime offloading?) breaks coolbits fan control on additional GPUs (1080Ti)

We have several machines running Fedora 30 and Centos 7 in our studio, they all have multiple GPUs used for GPU rendering, as such we need manual fan control since these GPUs are running loaded for days on end.

Things were working perfectly with the 430.40 drivers by adding additional X screens for the additional GPUs with the Option “AllowEmptyInitialConfiguration” and “Coolbits” “12”.

With what I’m assuming is the addition of the Prime offloading in the newer driver, this no longer works, and we now have this section in our log that I’ve gathered means the additional GPUs are being setup with the new prime offloading.

[  7683.738] (II) NVIDIA(G0): Validated MetaModes:
[  7683.738] (II) NVIDIA(G0):     "NULL"
[  7683.738] (II) NVIDIA(G0): Virtual screen size determined to be 640 x 480
[  7683.738] (WW) NVIDIA(G0): Unable to get display device for DPI computation.
[  7683.738] (==) NVIDIA(G0): DPI set to (75, 75); computed from built-in default
[  7683.740] (II) NVIDIA: Using 24576.00 MB of virtual memory for indirect memory
[  7683.740] (II) NVIDIA:     access.
...

[  7683.777] (WW) NVIDIA(G0): Option "Coolbits" is not used
[  7683.777] (WW) NVIDIA(G0): Option "metamodes" is not used

Running  xrandr --listproviders returns:

Providers: number : 2
Provider 0: id: 0x351 cap: 0x1, Source Output crtcs: 4 outputs: 9 associated providers: 0 name:NVIDIA-0
Provider 1: id: 0x1b8 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-G0

I tried Option “AllowNVIDIAGPUScreens” “False”, but it didn’t appear to disable anything.

Is there any way to get our old setup back, not having fan control on the additional GPUs is a huge issue as we need the newer drivers for Redshift rendering support.

Edit: I read the documentation on the Option “AllowNVIDIAGPUScreens” “boolean”

When this option is enabled, and the X server version supports GPU screens (xorg-server 1.13 or newer), the NVIDIA X driver will allow GPU screens to be created for each NVIDIA GPU detected in the system for which there is no X screen configured or auto-configured.

Default: false. The NVIDIA X driver will not allow GPU screens to be created unless this option is explicitly enabled.

This appears to not be working, as I’m getting screens created by default.
nvidia-bug-report.log.gz (1.71 MB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

I’ve added the nvidia-bug-report.log.gz, sorry about that.

The packaged driver you’re using is enbling that option in the file
/etc/X11/xorg.conf.d/10-nvidia.conf
just delete that and the behaviour should return to the normal state.

That worked! Thank you so much for the quick response. I’ll let the packager know so he can make a note for people that might run into this issue.

Might be that but it’s a bit confusing so it only helps if you know how it works:
https://rpmfusion.org/Howto/Optimus