440.44 : GeForce GTX 960M - Prime - vkcube freezes/crashes desktop

Hi.

This is my work laptop so Vulkan support is not hugely important right now, however may be used more in the future…

Running KDE Neon (+HWE) - kernel 5.0.0-37-generic - nvidia 440.44 (from PPA)

System works fine (in fact it performs really well with OpenGL) - however when I try to use vkcube - the cub starts spinning as normal for a few seconds - then my entire desktop freezes - I have to hard reboot to go back to the desktop…

I can’t see any useful logs.

Here is my vulkaninfo output : (not the initial error ->

WARNING: [Loader Message] Code 0 : loader_icd_scan: Can not find 'ICD' object in ICD JSON file /usr/share/vulkan/icd.d/nvidia_layers.json.  Skipping ICD JSON
INTEL-MESA: warning: ../src/intel/vulkan/anv_device.c:1250: FINISHME: Implement pop-free point clipping

How can I troubleshoot this ?

vulkaninfo output attached :-
vulkaninfo.txt (69.1 KB)

(see vulkaninfo.txt)

Please run nvidia-bug-report.sh as root immediately after reboot and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Thanks @generix

A bit more info… If I run vkcube and leave the mouse alone it works fine, as soon as I click the mouse (anywhere on the screen) it freezes (it feels like when you have a massive load - i.e you move the cursor and nothing happens…)

This time I was able to got to a TTY and kill vkheads…

I will attach the nvidia bug-report to this message.
nvidia-bug-report.log.gz (1.13 MB)

Please check if this is related to the known prime sync bug by turning it off:
xrandr --output eDP-1-1 --set “PRIME Synchronization” “0”

No - it still does the same…

There’s nothing suspicious to be found in the logs, only the notice

[ 19202.561] (WW) NVIDIA: Wait for channel idle timed out.

but that’s rather a symptom since the driver/gpu seems to be blocking. I also can’t reproduce it, vkcube runs fine on driver 440.44 for me.
Maybe two things to check:

  1. does disconnecting the external monitor or
  2. disabling composition in kwin change anything?

Composting setting doesn’t effect it - same bug

Disabling external display likewise - same bug

However …

If I disable 2nd monitor, then do

xrandr --output eDP-1-1 --set "PRIME Synchronization" "0" 

It doesn’t freeze - however the cude is spinning really fast (like insanely fast and looks wrong.)

edit :

After re-enabling 2nd monitor (after using the above “PRIME Synchronization” “0” command without 2nd display) the same thing works - i.e its spinning really fast (to the point you can’t tell if its a cube)

I’ve also got this same problem, I’m running Manjaro 18.1.5, Kernel 5.3.18-1, with Nvidia drivers 440.44 (from the manjaro extra repo) with X.Org X Server 1.20.6
I tried the aforementioned

xrandr --output eDP-1-1 --set "PRIME Synchronization" "0"

and had the same outcome, with the ridiculously spinny cube. (also have screen tearing after running that, but yeah.)
If I can help troubleshoot this, ping me.
myvulkaninfo.txt (34.6 KB)
nvidia-bug-report.log.gz (320 KB)

Update: I was using Nvidia PRIME on only my discrete graphics, but after switching to using both using the solution here https://forum.manjaro.org/t/merged-to-testing-adding-nvidia-prime-offloading-support-to-mhwd/108849/81 I don’t have the problem. This is only for Manjaro, but hopefully you can find a similar solution for KDE Neon.