[450.57] Low performance after resuming from suspend

Distro: Arch
DE: i3wm v.4.18.1
Card: gtx770

I’m experiencing notable performance drops after resuming from suspend with 450.57 driver on Arch. Before going to suspend everything works fine, but after resuming scrolling in browser and windows dragging become very laggy and choppy. I have set NVreg_RegisterForACPIEvents=1 and NVreg_EnableMSI=1 options for nvidia kernel module as ArchWiki suggests, but it doesn’t make any difference. Downgrading to 440.82 solves the problem.

nvidia-bug-report.log (521.4 KB)

Same issue here. Arch, GNOME on X11, 450.57, GTX 1080.

I notice there’s something wrong on Firefox, where usually WebRender is enabled and working, but after suspend it falls back to OpenGL and says in its log “Unflushed glGetGraphicsResetStatus: 0x92bb”.

I have experienced the same issue with 440.100, haven’t tested 440.82 yet, will do so now (UPDATE: unfortunately 440.82 doesn’t compile on 5.7.6, so I can’t test that version)

Issue fixes itself after restarting the whole X session (systemctl restart gdm in my case)

This is because nvidia package uses pre-built nvidia kernel modules. To compile you need to remove nvidia package and install nvidia-dkms package instead. It will automatically compile modules for your currently running kernel. To compile nvidia-dkms 440.82 you also need to downgrade nvidia-utils to the same version.

I am indeed using nvidia-dkms ONLY (not the pre-built ones) and downgraded both nvidia-dkms and nvidia-utils to 440.82, but still does not compile. Compiles just fine on the current Linux LTS version.

That’s strange.
I’ve just tried the 5.7.6 kernel, and everything is working fine for me.

Here’s the 440.82 compile errors: https://pastebin.com/raw/detzBMXQ

Anyway, let’s not pollute this thread, the issue is not 440.82 not compiling on 5.7.x, the issue is suspend causing issues.

I can partly confirm this. Since the driver upgrade, my firefox is horribly slow. I haven’t been in suspend, however before.

What logs are you referring to 1player

If you mean the Firefox logs, I have it installed from Flatpak and when I run it from shell with flatpak run org.mozilla.firefox, when the system is borked after suspend I get the output: Unflushed glGetGraphicsResetStatus: 0x92bb, which I don’t get after a reboot or restarting the X session.

The use of Flatpak is incidental, the behaviour and error appears even on the regular Arch Linux firefox package. Again, I have WebRender enabled on Firefox, so you might not see anything of the sort if you don’t.

Perhaps there’s some other way to reproduce this behaviour without using Firefox.

Ok, understand. I downgraded my driver now. Unfortunately, NVidia is a never ending nightmare with its drivers for Linux…

The things seem to be much better with 450.66, but I still have some freezes/stutters when scrolling in Firefox after resuming from suspend. Downgraded to 440.82 again.