460.56 Desktop primary monitor no longer powers on after locking, second monitor is fine (possibly regression in 460.56 driver)


Shortly after upgrading to NVIDIA driver 460.56 on my Ubuntu 18.04 install with 2 monitors, when I lock my computer and the displays turn off, if my 2 displays are off long enough, the primary display becomes unresponsive and I have to physically unplug the monitor and then plug it back in - but then of course, I have to re-arrange my desktop icons which is quite annoying. This did not happen before NVIDIA driver 460.56, I’ve had the same Linux kernel since January or February, and I don’t believe any other software has changed either. I see that 460.56 came out 2021/2/25 which is around when I started having these issues. This issue has become rather bothersome, and I’ve been running Ubuntu 18.04 since 2019 without any issues, Ubuntu 16.04 since 2017 without any issues, and the same GTX 1070 this whole time without any issues until just now. After the computer is locked each night and the displays are turned “off”, the VG248QE monitor in question has an orange LED indicating that the monitor is actually “on”, and you should be able to turn it off (resulting in no LED) or provide a signal to it (resulting in blue LED) or go through the monitor menu, switch sources, etc but the monitor has an orange LED and is completely unresponsive instead - it cannot even be turned off, it requires re-plugging the power cable of the monitor to even do anything. My second monitor, my PA248Q monitor, does not exhibit any of these symptoms and behaves normally all the time. In February and an entire 3 years prior, I did not have this problem and both monitors functioned completely normally.

This could be related to /t/460-56-no-desktop-on-resume-from-suspend-to-ram/170275, I think there was a regression in the 460.56 since I’m not the only one having issues with resuming from suspend/sleep and/or locking, and this was working fine for me before.

Here are my computer specs:
OS: Ubuntu 18.04.5 LTS x86_64
Kernel: 4.15.0-136-generic
Uptime: 1 day, 19 hours, 41 mins
Shell: zsh 5.4.2
Resolution: 1920x1200, 1920x1080
DE: Xfce
WM: Xfwm4
WM Theme: Default
Theme: Xfce-dusk [GTK2], Greybird [GTK3]
Icons: Elementary-xfce-darker [GTK2/3]
Terminal: xfce4-terminal
Terminal Font: Hack 12
CPU: Intel i7-5960X (16) @ 4.300GHz
GPU: NVIDIA GeForce GTX 1070
Memory: 14513MiB / 32081MiB

Here are some logs, including Xorg logs, dmesg logs, and journalctl logs:
Xorg: NVIDIA Xorg logs - Pastebin.com
Dmesg: NVIDIA dmesg logs - Pastebin.com
Journalctl: https://pastebin.com/jhFSuF5A

If anyone has any advice or things I could look into, or if this bug doesn’t seem to be related with NVIDIA but rather with Xfce or something else, please let me know.

Thank you.

I swapped out my VG248QE with a spare VG248QE I had, and the issue still persists. It’s definitely a software issue and not a hardware issue.

Here is the nvidia-bug-report.sh logs: https://paste.ee/p/96j6M

I worked around this issue by preventing my monitors from powering off and instead having it run a screensaver overnight: https://i.imgur.com/4sBiLCP.png

I might test 460.67 some time, hopefully that will fix the issue but if not at least I have a workaround. I’m a little bit surprised to see I don’t really see too many reports of this issue which definitely seems to be a software issue, and a regression at that.

This bug still happens in 460.67 unfortunately, and as mentioned previously it’s definitely not a hardware issue. I’m glad I found my workaround by preventing monitors from powering off and instead having it run a screensaver, because otherwise this bug may take a very long time to get fixed I’m thinking.

I had tried upgrading from Ubuntu 18.04 to 20.04, but the upgrade failed half-way through because libc6 had upgraded whereas libc-bin had not upgraded. I ended up having to clean install Ubuntu 20.04 and still experienced this primary monitor unresponsiveness bug with NVIDIA 460.73.1 on a clean install of Ubuntu 20.04.

This week I had upgraded to NVIDIA 460.80 and tested it again, and yet again I have experienced this primary monitor unresponsiveness bug - despite the fact that NVIDIA claims that this bug (or a similar one) is fixed in the changelog of NVIDIA 460.80: “Fixed a bug that could prevent a system from resuming from suspend when DisplayPort activity occurred while the system was suspended.” NVIDIA DRIVERS Linux x64 (AMD64/EM64T) Display Driver

Since I am still experiencing this issue, I will continue using my work-around (leaving XScreenSaver power management turned off) and I will likely no longer continue testing if this bug is fixed - I will assume that it remains broken, as it most likely will remain broken.