465.27 drivers cause a system freeze when Xorg is started

GPU: GTX 1070ti
Distros tested: Ubuntu 20.04, Kubuntu 20.04, Ubuntu 21.04.
Kernel: 5.11

After installing 465.27 I can’t get to a graphical login anymore. I tried both the Ubuntu PPA and the .run installer on multiple fresh installs of Ubuntu 20.04 and 21.04.

When Xorg is started by either gdm, sddm or even startx, the system just freezes and I can’t even switch to another tty.
System logs don’t show any error at all… It’s like it hangs before Xorg is even started.

The only way to recover from this is to forcefully shutdown the machine, reboot into the recovery console and reinstall a previous driver version. After reverting back to 460.73.01 everything is back to normal again.

Haven’t tried other distros yet but this looks like a driver regression to me.

1 Like

Another useless report, try posting something useful.

The reason why I didn’t attach anything is because the normal system logs really don’t show anything useful. Since the system hangs with no way to run nvidia-bug-report I can’t do anything about it. Except posting its output with a working driver version that would be completely useless.

I usually post very detailed reports but this time I honestly don’t know what to do other than simply posting as much information I know without cluttering the forum with completely useless info.

Nvidia really needs a decent public bug tracker…

I only read about two other people with a 1070ti that can’t seem to get Xorg running on the new 465 series. That would seem to indicate that this issue seems to only affect 1070tis…

Does dmesg show anything?

The bug causes a kernel panic, there’s no way to get any logs, ssh doesn’t work, the system instantly locks before dmesg shows anything, even if streamed to a file and re-read on next boot


I simply can’t run dmesg after the hang. Investigating the output of journalctl does not show any page fault like that other bug report. I didn’t try unplugging the display port cable and only use HDMI though… let’s see if that changes anything…

Hi. I am having Kernel panic problem here with 465 driver, but only when trying to resume from suspend to RAM. I use KDE Neon (Ubuntu 20.04), GTX 960. My monitor is connected to HDMI output.
I have already reported the problem.

And, as it turns out, unplugging the Display Port cable does in fact change something: HDMI works perfectly fine. As soon as I plug in a Display Port cable, the system immediately hangs.

Some people are describing the same symptoms in this post so, even if I can’t see the same errors in the logs, this issue is most likely a duplicate.

1 Like

Necrobumping cause this issue is still happening. I can confirm that with a single monitor plugged in via Displayport, any action related to the Nvidia driver hangs the system, hard. I’ve tested this on Arch and Solus over several months, currently the only solution is to hold the driver package back at 460.67. Using the nvidia-dkms package with several different kernels, it appears completely isolated to the Nvidia driver version. I didn’t see any mention of it in the 470 beta driver changelog either, so I’m afraid it’s happening to a small enough number of us that it’s not getting any traction.
As others have said, getting logs is nigh impossible, as it just goes dead, even remote syslog doesn’t help. I can trigger this just by running nvidia-smi from a shell booting into single user mode.
The info I can provide:

  • GPU 3080 FE
  • CPU 3900XT
  • 64G ram
  • 2x 1TB Gen4 m.2 NVME drives
  • 4K generic monitor
  • Happens across distros
  • Only affects displayport, same monitor on HDMI is OK.
  • Not all monitors on displayport cause the lock, my 3440x1440 AW3420DW doesn’t seem to demonstrate this behavior, whereas my 4K Monoprice ( IIIP ) monitor does.
  • 460.67 works fine, every driver release after it has the problem, regardless of kernels from 5.11 to 5.13