470xx drivers and linux 6.0 kernel

today i updated my opensuse tumbleweed system to linux kernel 6.0.
but when i tried to create the nvidia driver for that kernel it failed.
i uploaded the installer log to this post.
the first of multiple errors is:

/tmp/NVIDIA-Linux-x86_64-470.141.03/kernel/nvidia/nv-acpi.c:270:43: error: ‘struct acpi_device’ has no member named ‘children’
     270 |     list_for_each_safe(node, next, &device->children)

so, the question is, if and when does a kernel 6.0 compatible 470xx driver will be released?

nvidia-installer-error.log (120.4 KB)

1 Like

Same here…
Waiting for a patch or something.

hi again,
i found this, and it seems to work:

1 Like

It builds with this patch, but ACPI is once again slaughtered. With this patch and kernel 6.0, the backlighting is at full capacity and cannot be reduced.
A systemctl | grep backlight allows to notice the disappearance of systemd-backlight@backlight:nvidia_0.service.
Anyone has an idea how can this issue be fixed ?

What comand line is used to patch the driver using patch from link above ?
I have tried and not is possible patch showing error in patch line.

i patched it the following way:

  1. unpack the archive with ./NVIDIA-Linux-x86_64-470.141.03.run --extract-only
  2. cd NVIDIA-Linux-x86_64-470.141.03/kernel
  3. patch --verbose --backup --strip=1 --input=/path/to/kernel-6.0.patch


    Option         "RegistryDwords" "EnableBrightnessControl=1"
    Option         "Backlight" "nvidia_backlight"

to Device section in the xorg.conf file seems to have solved the backlight issue.

Your reply work. Thanks.
Hey the binary have an command line -apply-patch.
Is possible use the patch directly with that command option ?

The driver patched is working without problems in your machine ?
Here in not issues at moment.

Hey the binary have an command line -apply-patch.
Is possible use the patch directly with that command option ?

yes, but i don’t remember how this works.
therefor i do it the “manual” way…

thanks for this hint.
this works for me as well!

I tryed this patch on my Gentoo amd64 with kernel 6.0.5 and… it hangs loading the nvidia-drm module by generating a segmentation fault (invalid OPCODE). See here: https://forums.developer.nvidia.com/t/nvidia-470-141-03-kernel-6/229885/3?u=iade.gesso


I found a solution! :) See my last post here :)


Hi ** iade.gesso**

I used the patches from your post and everything worked for me now. Fedora 36 and kernel 6.0.5