4k Monitor cannot get maximum resolution and refresh rate in ubuntu

My setup:
laptop - MSI msi ge63 rgb 8se which has a 2060 mobile GPU
Monitor dell S721qs
Driver Version: 460.80
CUDA Version: 11.2
Nvidia-settings: version 470.42.01

I cannot get its max resolution in Ubuntu 20.04 . But it works well with windows .
Initially I had issues with windows too but changing the settings in intel HD graphics control panel solved that (changing the resolution in intel app rather than nvidia app)
I tried changing settings in Nvidia X server settings but max resolution that gives output is 1920*1080 with 23.98 Hz
any higher monitor goes black. I tried saving the X server setting in xconfig file and restarting but then it doesn’t boot to UI . had to remove /etc.X11/xorg.conf file to get the UI back
I have attached the nvidia-bug-report.log.gz file and x server settings that i’m trying to get
Please help
Thank you

xorg.conf (1.8 KB)
nvidia-bug-report.log.gz (406.4 KB)

Hey @samithajayaweera - did you ever get this working?