4k monitor capped at 30hz on ubuntu

Hi there,

So I have an Acer Preadator Helios laptop with a GTX 1050ti. I have an ACER XB281HK monitor. I am using Ubuntu but the refresh rate is capped at 30hz and its capable of doing 60hz. I have a desktop i use with the same monitor and it runs 60hz fine (on windows) using the same HDMI 2.0 cable.

Any help to get it running 60hz would be great.

Regards
Seb

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

nvidia-bug-report.log.log (371.7 KB)

Is this ok?

The monitor only supports 4k@30 or FHD@60 over HDMI, confirmed by

  • monitors edid
  • datasheet from acer
  • windows driver .inf from acer

it supports 4k@60 over DisplayPort only.
Furthermore, the edid tells that it also doesn’t support color subsampling in order to get 4k@60 YCrCb 4:2:0 over hdmi.
So I really doubt you got 4k@60 over hdmi on Windows, should be technically impossible unless it uses a custom edid unlocking undocumented features.
Please use on Windows to display/extract edid:
https://www.nirsoft.net/utils/monitor_info_view.html

Decoded edid from monitor:

Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   04 72 61 04 12 8c 30 64 2b 1a
version:         01 03
basic params:    80 42 25 78 0e
chroma info:     ee 91 a3 54 4c 99 26 0f 50 54
established:     21 08 00
standard:        01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
descriptor 1:    02 3a 80 18 71 38 2d 40 58 2c 45 00 98 76 21 00 00 1e
descriptor 2:    00 00 00 ff 00 54 34 52 45 45 30 30 31 34 32 30 31 0a
descriptor 3:    00 00 00 fd 00 18 3c 1e 8c 1e 01 0a 20 20 20 20 20 20
descriptor 4:    00 00 00 fc 00 41 63 65 72 20 58 42 32 38 31 48 4b 0a
extensions:      01
checksum:        c3

Manufacturer: ACR Model 461 Serial Number 1680903186
Made week 43 of 2016
EDID version: 1.3
Digital display
Maximum image size: 66 cm x 37 cm
Gamma: 2.20
Supported color formats: RGB 4:4:4, YCrCb 4:4:4
Default (sRGB) color space is primary color space
First detailed timing is preferred timing
Established timings supported:
  640x480@60Hz
  800x600@60Hz
  1024x768@60Hz
Standard timings supported:
Detailed mode: Clock 148.500 MHz, 664 mm x 374 mm
               1920 2008 2052 2200 hborder 0
               1080 1084 1089 1125 vborder 0
               +hsync +vsync 
Serial number: T4REE0014201
Monitor ranges (bare limits): 24-60Hz V, 30-140kHz H, max dotclock 300MHz
Monitor name: Acer XB281HK
Has 1 extension blocks
Checksum: 0xc3 (valid)

CEA extension block
Extension version: 3
31 bytes of CEA data
  Video data block
    VIC  16 1920x1080@60Hz 
    VIC  31 1920x1080@50Hz 
    VIC   4 1280x720@60Hz 
    VIC  19 1280x720@50Hz 
    VIC   3 720x480@60Hz 
    VIC  18 720x576@50Hz 
    VIC   1 640x480@60Hz 
    VIC  93 3840x2160@24Hz 
    VIC 223 Unknown mode 
  Audio data block
    Linear PCM, max channels 2
    Supported sample rates (kHz): 48 44.1 32
    Supported sample sizes (bits): 16
  Speaker allocation data block
    Speaker map: FL/FR
  Vendor-specific data block, OUI 000c03 (HDMI)
    Source physical address 1.0.0.0
    Maximum TMDS clock: 300MHz
    Extended HDMI video details:
      Base EDID image size is in units of 1cm
      HDMI VIC 2 3840x2160@24Hz
      HDMI VIC 0 3840x2160@30Hz
Underscans PC formats by default
Basic audio support
1 native detailed modes
Checksum: 0x43 (valid)

EDID block does not conform at all!
	Detailed blocks filled with garbage
	Range descriptor contains garbage

Ok, no problem. Sounds right actually. I used to use HDMI with the desktop but forgot i switched to display port a few months back. Apologies for the confusion.

Hi,

So I’ve encountered another issue. I stupidly tried to adjust settings in xrandr (previous to starting this thread) I rebooted my laptop and not the native screen wont display and only the HDMI (the acer monitor). Im presuming i need to reset the xrandr and nvidia settings however id rather not make the problem worse