545 driver: desktop framerate alternates between 120 and 60 FPS

~/.config/plasma-workspace/env/kwin.sh

#!/bin/sh
export KWIN_X11_FORCE_SOFTWARE_VSYNC=1

Fixes fluctations (as suggested by valgusk) - but without disabling vsync.

I can’t use this workaround, unfortunately, as I have kwin vsync disabled altogether with “force composition pipeline” enabled in the NVIDIA driver. It’s the only way I can get vsync on my two monitors with differential refresh rates (120 Hz & 75 Hz):

export KWIN_X11_NO_SYNC_TO_VBLANK=1
export KWIN_X11_REFRESH_RATE=120000

This is just to keep updated that team is currently debugging the issue.

2 Likes

I’ve been browsing the web for days to finally find a post with this issue.

KDE on NVidia always was a bad experience but this made it even worse. It’s so bad that even games are really laggy while MangoHud displays a constant 75 FPS.

1 Like

To be fair, this doesn’t affect games when compositing is disabled, but it’s definitely not optimal in normal desktop use. Hoping the team finds a resolution soon.

2 Likes

I can back up this claim. Launching a game with compositing disabled, fps and performance in game is perfect running X11 under the 545’s.

The workaround of setting KWIN_X11_FORCE_SOFTWARE_VSYNC=1 helps until they fix it soon hopefully.

@amrits
Are there any significant updates on this particular issue, is it still being debugged ?

The root cause was found and it should be fixed in a future release.

2 Likes

Great news! Is it going to be mentioned in the release highlights? Or only here?

In 555 or in a future minor release of 545?

1 Like

Gave the 550 beta driver a try, and sure enough the desktop framerate on Plasma seems to be fine without forcing software vsync now.
I’m guessing this can be marked as resolved as soon as it’s marked stable?

I installed the 550 beta driver and I still see the same behavior I saw on 545. Framerate is constantly under 60 FPS (I have a 165Hz external display) but enabling VRR in Plasma display settings does increase my framerate to around 100-120fps on the desktop (doing so in 545 also yielded the same result).
Seems like the fix is not incorporated yet in the 550 beta or doesn’t work in some scenarios.

SYSTEM SPECS:

  • OS: Kubuntu 23.10 Mantic, kernel 6.5.0-15-generic
  • DE: KDE plasma 5.27.10 using Wayland
  • Driver Version: 550.40.07
  • GPU: RTX 3060 6GB mobile + intel iris XE graphics (no mux switch)
  • CPU: 12th Gen Intel(R) Core™ i9-12900HK
  • Machine: Dell XPS 17 9720 laptop
  • External Monitor: Cooler Master GM-27FQ (Enabled)
  • Built-in Display: 4k 3840x2400@60Hz 16:10 (disabled and laptop lid is closed)
  • Extras: Machine internal display is disabled and connected to a1440p 165Hz external monitor. Dell Direct Graphics Controller Direct Output mode is enabled in the UEFI and monitor is connected through a TB4 to DP cable on the upper left side port.
1 Like

Issue fixed on my end with the latest nvidia driver ( 550.54.14 ).

Thanks to the small team behind the Drivers. I wonder how many people work on the Windows driver comparing it to the Linux team.