545 drivers have bad flickering and black screen issues when VRR is enabled

Your issue is different. I am not just talking about Wayland. VRR in Xorg is also broken. It is also not a glitch or graphical corruption. The entire screen blanks out.

Here’s a video I took showing the issue: https://www.youtube.com/watch?v=tC2EiMQBbcI

With Gsync enabled in the Nvidia settings, you can see the screen flickering and fully blanking out when the game dips below a certain framerate. If I stare at the sky it briefly comes back. This happens in every game, not just the Talos Principle II.

@aplattner can we get some acknowledgement on this issue? This is a regression from the 535 series and it would be a shame for this to make it into the stable 545 build.

The panel is an LG C2 42 inch connected via HDMI 2.1

This issue doesn’t seem limited to VRR, I experience it in normal desktop and sometimes my desktop would even flicker on the main monitor.
Attaching bug report.

nvidia-bug-report.log.gz (1.3 MB)

EDIT: Reverted to 535 and issue is gone.

EDIT2: spoke too soon same issue present

EDIT3: sorry for so many edits, it seems like the culprit was kscreen settings, which I removed and upon recreating it seems all fine now.

Can you explain what kscreen settings you’re talking about? Wondering if that’s causing my issues here as well.

Yes, kscreen is additional kde thing to get display data, you can completely reset it by removing the stored settings in - ~/.local/share/kscreen afaik it stores for both xorg and wayland.

I deleted the entire kscreen folder and I am still seeing the VRR issue.

Sigh, it would appear that this bug made it into the stable release. I am still seeing this issue with the 545.29.02 drivers. I have to ask question why Nvidia even bothers doing beta releases if they’re not going to listen to user feedback and just release the broken drivers anyways.

I just tested with Control. When the game isn’t flickering or simply displaying a black screen, it also seems like its delivering frames out of order. It’s very apparent when panning the camera.

I’ve generated another bug report log in case the devs are interested:
nvidia-bug-report.log.gz (730.5 KB)

1 Like

Heya, you mention in the OG post you encounter the same thing in Xorg, I’m unable to reproduce such scenario on Xorg(I had some other weird flickers which turned out to be very random and only when all 3 of my monitors are on, but very similar to what you explain here). Is it still happening under both ? On wayland I just have the top horizontal line tear.

EDIT: Just to rule it out - have you tried with a different HDMI cable(I assume you have it connected via HDMI)

1 Like

I also have this issue on my 3060 since I updated to the latest driver, Video playback felt really sluggish (Frames breing jumbled up, constant flickering, and overall nauseating experience) as well as every single game being run on wayland, and since im on a Lenovo G24-10 monitor that is G-Sync compatible yet doesn’t offer me the option to turn it off within nvidia-settings, I’m stuck with either downgrading to the 535 series or going to fallback to X, I really can’t figure how this bug slipped to the final release.
Apparently what I was experiencing with the new 545 drivers is related to this issue.

Here’s my logs:
nvidia-bug-report.log.gz (937.7 KB)

1 Like

@kodatarule Yes, it happens on both Xorg and Wayland. I don’t think its due to the HDMI cable because if I revert to the 535 drivers everything works fine. Something was definitely introduced with 545. When I am on the desktop, my monitor is constantly showing a VRR refresh rate of 121 or 122, which is slightly above the 120 hz refresh rate of the panel, whereas before with the 535 drivers it would show a stable 119. There’s something funky going on with the sync for sure.

@SlamZDank Are you on KDE Wayland? There’s an option to turn off VRR in the Display Settings.


Yes, I’m using KDE, but there are no such options also in System Settings.

Also encountering this same issue on Arch Linux using a 4090 and 545. I’m using a Samsung 75” Class QN85B at 120Hz. If I go back to driver version 535, it doesn’t happen and 120fps works fine.

We have filed a bug [4363431] internally for tracking purpose.
We tried locally on couple of setups but unfortunately not able to replicate issue so far.
We will continue with local repro efforts and also engineering team is trying to root cause issue based up on attached logs as we do not have local repro yet.


@amrits It seems like specific combinations of hardware cause this and not everyone has this issue, at least in my conversations with other Linux users. Not sure if the dev team can get their hands on a LG C2 panel 42 inch + an Asus TUF Nvidia 3090 OC, but I’ve been able to consistently reproduce this issue with this combo and the 545 drivers.

Let us know if there’s any other info you need from me. Happy to help expedite a fix for this issue as it’s a total buzzkill when it comes to gaming on my Arch Linux box right now.

1 Like

I am not sure if it is related, but this seems to affect 120hz displays, my setup are both 165hz and Samsung QN90B is 144hz which is perhaps the reason why we cannot reproduce.


I’ve had the flicker problem forever, not sure what causes it however, it mainly only occurs If the system wakes from suspend in single monitor mode. It flickers black or displays nothing because it is stuck somehow with vrr. By enabling my second monitor (non-gsync secondary) the screens reset, and I can disable the second monitor again to have vrr working without a black screen.

This normally happens randomly after suspend or after the screen has timed out due to dpms

You might be onto something, I’m having this issue on an LG C2, which is 120hz.

1 Like

Same problem on a 170hz display

1 Like

What display do you have? It might help Nvidia devs to know what specific hardware.

1 Like

You can repro with:

  • Arch Linuux
  • Nvidia 545
  • Samsung G95NC

and running

swaymsg output HDMI-A-1 scale 1.25 resolution 7680x2160@59.987Hz

This will cause flickering on 545 but not on 535.


swaymsg output HDMI-A-1 adaptive_sync on 

Fixes flickering on 545, but will cause black screen.

1 Like