560 Ti and CUDA 5.5

I’m using a 560TI part and just tried to update to CUDA 5.5. Before this, I discovered that video drivers newer than 314.22 would crash my system (Windows 7 64 bit) so I have kept them at that level. However, after making updates to the code to CUDA 5.5 - I get

cudaErrorInsufficientDriver = 35

when trying to select a device.

Any advice for this situation?


CUDA 5.5 requires a version 319 driver (or newer). I’d recommend trying some of the newer drivers (latest 319, latest 325, latest 331) and see if they fix the system crash you’ve experienced.

The error was: ‘A clock interrupt was not received on a secondary processor’ with a full crash. I did try two different newer drivers both had this problem, including the latest one. I also updated by BIOS to the latest one for my Gigabyte P55A-UD4P mainboard. The problem persisted, a random crash maybe on average after 5-10 minutes - doing anything on the computer, not necessarily graphics intensive stuff.

I found a thread on the net somewhere that the 314 one would eliminate the problem. And it did. Since I do a lot of work on this machine, I am very reluctant to change it again. Note that the 314 driver was still newer from my driver when I started the update.

Could it be possible that the newer drivers are exposing a hardware problem that exists but isn’t exposed with the older driver?

I found this on reddit (http://www.reddit.com/r/battlefield_4/comments/1qz7vx/nvidia_releases_geforce_33182_whql_driver_claims/) … does hardware acceleration in Firefox have something to do with this?

I’m going to give it another try with 331.65 drivers.

[–]fletchowns 2 points 6 days ago

For reals, I’m still on 314.22 for my 460GTX. Anything newer and my computer bluescreens every 5 minutes with “clock interrupt was not received on a secondary processor within the allocated time interval”.


[–]Craazygnome 2 points 5 days ago

Try turning off hardware acceleration in firefox if that’s what your running. That is what was causing my 560 to crash on drivers after 314.22. Been running the newest drivers since bf4 beta with no hardware crashes.


[–]fletchowns 1 point 3 days ago

Firefox is in fact my primary browser. I disabled hardware acceleration and updated my drivers to 331.65. Haven’t crashed in a couple days! Thanks for the tip!!


[–]Craazygnome 2 points 3 days ago

That’s great to hear! Glad I could help.

Well, I think this is solved. The crash happens in Firefox when hardware acceleration is on. It doesn’t happen for drivers before 314. I tried to see if there was a place to add bug reports for Firefox but couldn’t find a site for that … maybe nVidia has some contacts over there and can report it.