A memory problem cause I can't use "VS" in API inspector

I am using Vulkan 1.3 to program, and I am adding a shadow map function into my work(uncompleted). But when I am using Nsight graphics to debug my program, after I clicked the “VS” in the API inspector when I want to check my vertex stage information, I can saw in the Windows Task that the memory usage by NVIDIA Nsight Graphics is increasing fast and Nsight graphics is no response, finally my computer directly went to shut down.
There are mainly 3 stage of my program, shadow map stage, scene stage, and IMGUI stage, the ‘VS’ is working well when drawing IMGUI, but crashing in shadow map stage and scene stage.

Thank you for using Nsight Graphics and I am sorry you running into this issue with a crash when using the VS in the API Inspector. What version of Nsight Graphics are you using? Which GPU driver do you have?

I have tried on 2023.2 and 2022.7, GPU driver is 536.23
GPU: RTX 2070, laptop
CPU: i5-10400

Thanks for the additional details. Can you take a look at the suggested steps in the Nsight Graphics documentation here to see if it helps User Guide :: Nsight Graphics Documentation.

If not are you able to send a crash dump to dwoods@nvidia.com by following the steps here User Guide :: Nsight Graphics Documentation?



I have solved this problem.
I have created a struct ubo with 1000 model matrixes, it’s too large, I reduce it to 20, then problem solved.
But I still don’t know why NVidia graphics applying for so many memories. ==