A problem about reflash for tx1

Hi guys, I have a problem, when I make system for TX1 with Jetspack3.1, the terminal stops at “BR_CID” and nothing happens for a long time, I have tried many times, it is still the same, how to solve this problem, thanks.

3.1 is rather old. Does the flash stop there and just hang? Is your host Ubuntu 16.04? In some of the older releases Ubuntu 18.04 hosts did not necessarily work (yet).

Yes, the cursor will stay there all the time, every time, when I use Ctrl+ C to end it, I check the log, the last display is “Boot ROM Communication Failed Error Return Value 3”, before I refresh TX1, I use Jetpack3.1 to refresh TX2, and successful, I use the virtual machine Ubuntu1604, host is Kali

When I use SDK Manager1.4 to try to install the system for TX1, I stop at 99% again and look at the terminal diagram. It seems to be the same problem


The error of not finding the boot ROM is very likely due to the VM not being configured to always pass the USB through to the guest o/s. During a flash the USB will repeatedly disconnect and reconnect, and unless your parent o/s is set up correctly to always give the USB back to the right o/s it will fail like this. VMs are not officially supported, but can work if configured correctly.

Incidentally, I do recommend a much newer JetPack. The older JetPack should work quite well from an Ubuntu 16.04 host PC, and technically so should the newer JetPacks, but on newer JetPacks I think an Ubuntu 18.04 host PC works better (or at least more consistently).

Thanks LinuxDev, I have tried the latest version of JetPack and SDKManager, the results are still the same, and the USB is always connected automatically when it is disconnected and reconnected.

The disconnect/reconnect is “logical” and not physical. I’m not sure you could say USB is always connected from disconnect/reconnect without advanced knowledge of the VM itself. As an experiment, when it gets to a failure point, you might try to physically unplug and replug the USB. Either way though, if you can’t get it to work as is, the answer will most likely be that you have to use a native Ubuntu 18.04 and a VM would not be allowed. VMs are notorious for this issue.

OK, thanks a lot. I may have some difficulties using Ubuntu on the physical machine and may need to try it in a few days. I would like to ask if there is a hardware problem with TX1

There is no way to know if there is a problem without using a non-VM for flash. Issues like what you encountered are far more often software issues than hardware issues. My bet is that the VM is in the way, but you could end up with the same issue via a non-VM…in which case it would be a hardware issue. As said though, this sort of problem is rare for a non-VM, and very very common when using a VM.

Thank you. I’ll try again