a problem of tution'twodaystoademo'

When I moved to the part ‘Building From Source On Jetson’ and the step ‘Configuring with CMake’, after I entered the code ‘cmake …/’, there seems to have a connection problem.The results are pasted below:

--2018-03-06 17:52:20--  (try: 5)  https://nvidia.app.box.com/shared/static/gzr5iewf5aouhc5exhp3higw6lzhcysj.gz
Connecting to nvidia.app.box.com (nvidia.app.box.com)|203.98.7.65|:443... failed: Connection timed out.
Retrying.

Could anyone help me to solve this problem? Thanks a lot!

Does “host nvidia.app.box.com” find an associated dotted-decimal IP address? This should show something like:

# host nvidia.app.box.com
nvidia.app.box.com is an alias for wildcard.app.box.com.
wildcard.app.box.com has address 107.152.24.199
wildcard.app.box.com has address 107.152.25.199

Next, does ping see the dotted-decimal address (“ping 107.152.24.199”)?

Finally, port 443 is SSL, so you can use a browser directly to this address:
https://nvidia.app.box.com

When you get there it wants a password. If you get that far, then it might be that your application is working fine, but the password prompt wasn’t offered. I’m not sure how your application works with password requests.

NOTE: I tried logging in, apparently it needs a different login than forums.

Thank you for answering my question!

Firstly, I do not have the result like you. At most time,it shows "connection timed out"like i quoted in the question, and at the rest of time, I got such result:

--2018-03-07 01:42:21--  https://nvidia.box.com/shared/static/5z3l76p8ap4n0o6rk7lyasdog9f14gc7.prototxt
Resolving nvidia.box.com (nvidia.box.com)... 107.152.24.197
Connecting to nvidia.box.com (nvidia.box.com)|107.152.24.197|:443... connected.
WARNING: cannot verify nvidia.box.com's certificate, issued by ‘CN=GeoTrust SSL CA - G3,O=GeoTrust Inc.,C=US’:
  Unable to locally verify the issuer's authority.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://nvidia.app.box.com/shared/static/5z3l76p8ap4n0o6rk7lyasdog9f14gc7.prototxt [following]

Secondly, I can ping 107.152.24.199 successfully, but I cannot ping nvidia.app.box.com or wildcard.app.box.com

Thirdly, I have tried to access https://nvidia.app.box.com, but I failed. It seems this website is blocked in China, since I access https://nvidia.app.box.com succesfully on my phone via VPN.

Could you give more advice? If it is a network problem could you guide me to set VPN on the TX1?

Thanks!

Hi YuefanYU,

I am checking this. Sorry for your inconvenience.

Thank you for answering my question!

Now, I have set a VPN so that I can access nvidia.app.box.com via browser. However, using the command “wget” to download files from nvidia.app.box.com still does not work. It shows that “connection timed out”.

Finally, I solved this problem.

The reason of this problem is that China block the access to nvidia.app.box.com.

Here is my way to solve this problem.
I use LANTERN to access this website on my host PC, therefore, I can wget files. However, LANTERN is not supported on TX1 because its core is arm64 and LANTERN also works on amd64. Then, I use HTTP PROXY on TX1 to access nvidia.app.box.com. It does work when I access to the website on browser, but not in the terminal. Finally, I download all files at host PC and copy them to TX1.

Thanks again for your help! I am very grateful that we have such a energetic forum to solve my problem!

I am also a Chinese user, you can modify the file CMakePreBuild. sh. Remove the code to download and uncompress the Caffe network model. In addition, the Caffe network model, I put it on the Baidu network disk. You can go download. After the download is complete, you need to extract the decompression, and then put them in the /jetson-inference/data/networks path.
Baidu networkd disk link:https://pan.baidu.com/share/init?surl=6rFmIRMzvcrskiaPonnOtQ
Password:rtr4

For those unable to access Box.com, here is a mirror on GitHub of all the models from the repo:

https://github.com/dusty-nv/jetson-inference/releases