A USB3 POINTGREY FL3-U3-88S2C-C camera not reconized by Jetson TX2

Hi

We try to connect and use a USB3 POINTGREY cam with a Jetson TX2
The cam is not recognized by TX2 on USB3 port.

We have this error reported with dmsg command:
[ 173.713209] usb usb2-port1: config error
[ 175.914867] usb 2-1: Device not responding to setup address.
[ 177.769596] usb 2-1: Device not responding to setup address.
[ 177.977294] usb 2-1: device not accepting address 13, error -71

The system trys different address but always fail;

Hardware we use:
Jetson TX2 with L4T R28.2.1 based on Ubuntu 16.04LTS with the Nvidia DEV kit
Camera: POINTGREY FL3-U3-88S2C-C firmware FLEA3 USB3-2.07 .3
The cam sensor is a SONY IMX121
Jet pack 3.3 installed on Ubuntu PC 14.04LTS

Thinks that work:
Camera on Ubuntu i385 architecture UBUNTU PC 14.04 works on USB3 port with Flycapture2 and Spinnnaker
Same in Windows 7 PC
On Jetson TX2 camera is detected when connected to USB2 port.
We use 2 cam and 2 Jetson TX2 modules and we made cross test to ensure that our problem is not due to hardware failure.
Other USB3 device like USB flash key works correctly on TX2

Tests we tried:
Increase buffer size with a command like:
Sudo sh –c ’echo 1024 in /sys/module/usbcore /parameters/ubsfs_memory_mb’ : not work
Cam powered by an external power source: not work
Test with Flycapture and Spinnaker : not work

Kernel compilation with a lot of usb driver checked, like:
All usb miscalenous driver
UVC
IMX219 driver
And a lot of other driver related to USB

Nota : Jetpack installation fails on Ubuntu with French language setting ‘non EN local OS supported’ error

Please check if below post helps:
https://devtalk.nvidia.com/default/topic/997340/jetson-tx1/how-to-capture-the-images-from-pointgrey-camera-with-jetson-tx1-/post/5099077/#5099077

Thanks for your reply DaneLLL.

We tried :
Avira and all the advises in this post with no-more success :-(
We also tried others USB3 cables ! In case if it is hardware problem.

We tried a Auvidea J130 carrier board with its patch with no more success.

I am curious…does this camera mention any kind of separate install for the firmware? Sometimes the camera is flashed for firmware and it remains in the camera, but sometimes devices needing firmware actually need this on the host and then the host uploads firmware at run time or on initial boot.

Hi Linuxdev
For this device, the firmware stays in camera’s flash but the cam needs a special FLIR/POINTGREY software to work. It is Flycaptur2 or Spinnaker.

To day we received a Jetson Xavier and we’ll can start new test with this platform !
We also got a Logitech Brio cam to perform some little test and it seems that the Cam is directly detected by the TX2 on USB3 port.