A30 Cuda nsys-ui error on RHEL 8.5

I am getting the below error, any help would be genuinely appreciated.

[root@node1 ~]# lspci -vnn | grep NVIDIA
21:00.0 3D controller [0302]: NVIDIA Corporation GA100GL [A30 PCIe] [10de:20b7] (rev a1)
Subsystem: NVIDIA Corporation Device [10de:1532]
e2:00.0 3D controller [0302]: NVIDIA Corporation GA100GL [A30 PCIe] [10de:20b7] (rev a1)
Subsystem: NVIDIA Corporation Device [10de:1532]

[root@node1 ~]# /usr/local/cuda-11.6/bin/nsys-ui
libk5crypto.so.3 requires EVP_KDF_ctrl. Switching to system OpenSSL libraries
Warning: Failed to get OpenGL version. OpenGL version 2.0 or higher is required.
OpenGL version is too low (0). Falling back to Mesa software rendering.
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: offscreen, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

/opt/nvidia/nsight-systems/2021.5.2/host-linux-x64/nsys-ui: line 51: 13862 Aborted (core dumped) “$NV_AGORA_PATH/CrashReporter” --hide-stack “NVIDIA Nsight Systems” “NsightSystems” “2021.5.2 (Build 2021.5.2.53-28d0e6e)” “$NV_QUADD_PATH” “$@”

Moved to Nsight Systems forum