Abnormal kafka message intervals for deepstream_parallel_inference_app

We run deepstream on jetson xaiver nx board , and found a new problem when checking the kafka message frequency. Our original camra is 25 fps,and we set the model inference interval are zero. So I think the message should be at least 5 or more per second. But we just got one message per second. I’m not clear if any wrong settings cause such problem。 And we herein provide the settings and message content as below:

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)

• DeepStream Version

• JetPack Version (valid for Jetson only)

• TensorRT Version

• NVIDIA GPU Driver Version (valid for GPU only)

• Issue Type( questions, new requirements, bugs)

• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

sorry, I miss such information. Now I add these:
Jetson Xaiver NX with JetPack 5.1 and deepstream 6.1, and TensorRT version is 8.5.2.2

please find frame-interval in the doc. the default value is 30. you can modify it.

Does it mean the message would be sent once by 30 frames-interval? But if the model infer all these frames, the last frame inference result would be sent?

yes. since it is configurable, you can set it to 0 in the cfg.

We just set the frame-interval to 1, but still got similar message frequency as before. Here I provide our config file and kafka message snapshoot for your reference as below:
deepstream_app_config.txt (7.4 KB)

please set msg-conv-frame-interval=1 in message-converter: part. if still can’t work, nvmsgconv and nvmsgborker are opensource. you can add log in gst_nvmsgconv_transform_ip_video_audio to check if self->frameInterval takes effect.

Thanks. We just add the msg-conv-frame-interval=1 in message-converter, with frame-interval=1 activate or deactivate in sink2 setting. But both are useless…

I will check your suggestion to confirm whether the self->frameInterval takes effect

I just add log to check the setting, and found the parameter not taking effect. Snapshoots are as below:

Thanks for the sharing! seems this value is not passed to the plugin. you can add “frame-interval”, convConfig->conv_frame_interval, in this code.

Ok, thanks. It seems the seting of msg2p-newapi is still also not updated, which I had asked months ago;
How to set the msg-broker if use my own model when running the code of deepstream_paraller_infer - Intelligent Video Analytics / DeepStream SDK - NVIDIA Developer Forums

1 Like