About Install JetPack

I’m using Jetson TX1 Development Kit(Ubuntu 16.04). I installed JetPack 2.3.1 using ‘wlan0’. Is it wrong?
I think it’s not wrong, but several folder don’t exist that write in manual, release note, read me and guide.

And I want to use on-board camera( MIPI/CSI Camera ) to Image-processing, but it has error.

Code ( This is code on Tutorial Video2) :
#include <opencv2/imgproc/imgproc.hpp>
#include <opencv2/highgui/highgui.hpp>

int main()
{
cv::Mat img = cv::imread(“lena.png”);

cv::Mat dst;
cv::Sobel(img, dst, CV_32F, 1, 1);


cv::imwrite("lena_sobel.png", dst);

cv::VideoCapture input(0);

// cv::VideoCapture input(“gst-launch-1.0 nvcamerasrc fpsRange=(30.0 30.0) ! ‘video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)I420, framerate=(fraction)30/1’ ! nvtee ! nvvidconv flip-method=2 ! ‘video/x-raw(memory:NVMM), format=(string)I420’ ! nvoverlaysink -e”);

for(;;)
{
    if (!input.read(img))
        break;

    cv::imshow("img", img);
    char c = cv::waitKey(30);

    if (c == 27)
        break;
}

}

when I use

cv::VideoCapture input(0);

the error is

‘HIGHGUI ERROR: V4L2: Pixel format of incoming image is unsupported by OpenCV’

when I use

cv::VideoCapture input(“gst-launch-1.0 nvcamerasrc fpsRange=(30.0 30.0) ! ‘video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)I420, framerate=(fraction)30/1’ ! nvtee ! nvvidconv flip-method=2 ! ‘video/x-raw(memory:NVMM), format=(string)I420’ ! nvoverlaysink -e”);

there is no error, but video isn’t printed.

ubuntu@tegra-ubuntu:~/2-cv-io$ make -C build && ./build/cv_io
make: Entering directory ‘/home/ubuntu/2-cv-io/build’
make[1]: Entering directory ‘/home/ubuntu/2-cv-io/build’
make[2]: Entering directory ‘/home/ubuntu/2-cv-io/build’
Scanning dependencies of target cv_io
make[2]: Leaving directory ‘/home/ubuntu/2-cv-io/build’
make[2]: Entering directory ‘/home/ubuntu/2-cv-io/build’
[ 50%] Building CXX object CMakeFiles/cv_io.dir/io.cpp.o
[100%] Linking CXX executable cv_io
make[2]: Leaving directory ‘/home/ubuntu/2-cv-io/build’
[100%] Built target cv_io
make[1]: Leaving directory ‘/home/ubuntu/2-cv-io/build’
make: Leaving directory ‘/home/ubuntu/2-cv-io/build’

Hi S_HJ,

Please follow below link steps to install JetPack:
http://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/l4t/2.3.1/jetpack_l4t_install.htm

I did follow that link, but I used wi-fi, not ethernet. Is this problem?

Can you see the camera preview by gstreamer? I don’t thing it about the install problem.

gst-launch-1.0 nvcamerasrc fpsRange=(30.0 30.0) ! 'video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)I420, framerate=(fraction)30/1' ! nvtee ! nvvidconv flip-method=2 ! 'video/x-raw(memory:NVMM), format=(string)I420' ! nvoverlaysink -e