About rendering quality

I am playing with machinima rendering tools.
I got my old attic scene renreder out nicely with realtime RTX but the scene looks so much better in Path Traced when working on it :/

See here default setting realtime render:

And Path Traced:

So noise is a huge problem here…
I raised the path traced rendering settings to this:

So from 1 to 20 and at the same the rendering time raised to average 14 sec/frame. Here is the result, just the start:

So noise in the fog is still so bad that this cannot be used. In my opinion the realtime RTX render engine is way better for animations. I am aiming to virtual desktop @ nucleus server kinda setup so I cannot blow the render times this much!

So what are the most important settings & sliders in Machinima, that I have to use if I want to make my realtime renders even better?

Pekka

1 Like

I raised the RTX real-time resolution to 3000 and played with rendering settings just by feeling:

Here is the result:

I can live with this for now :) and continue studying other animation tools of Machinima & creating my own projects.
But someone can point me out what are the most important settings, that would be cool.

1 Like

all right!

This is made with RTX real-time high settings. But what are those strange jumping shadows at the background?

Pekka

Hey Pekka!

One thing I noticed was your PT settings, note the first setting (samples per pixel per iteration) doesn’t actually increase your quality, it is what we use to spread load across multiple GPU’s.

For your motion, you should be increasing your motionblur frames to something around 30 or 32 for this type of camera motion, and then slowing increasing your path traced samples per pixel. How this works is each iteration of motionblur is effectively one sample and you multiply that by your path traced samples per pixel.

I use this for instance for a heavy fog scene:

image

This is effectively 5 x 32 = 160 samples.

I’ll have some take a look at the jumping shadows, looks like occlusion artifacts?

1 Like

Thank you Dane!
I concentrate now on RTX real-time renderings.
I cannot get the jumping lights off, no matter what I do.
Even if I have render settings / Ray Tracing / Direct Lighting totally OFF, I still see them lights jumping in Machinima realtime viewport at pause ( no seq/camera playback),

Working a repro here now, will let you know!

I’ve repro’ed the issue, it looks like its related to indirect GI, I’ve found some good settings to mitigate the issue on this particular sample. Will let you know soon!

1 Like

Great to hear this!!

anyone reading this far might want to check this out:

1 Like